Windows 10 Mail app in the wrong language

After upgrading my Surface Pro to Windows 10, the Mail app is in French, while everything else is in English. I removed French as a language on my Surface, but Mail still insists on being in French.

How do I change it to English? Windows Display Language is set to English (Canada).

Answer
Answer

I was experiencing the same problem but with the People app which was showing in Arabic instead of English. I am using both English and Arabic as input methods and managed to fix the issue by doing the following:

  1. Go to Control Panel\Clock, Language and Region\Language
  2. Ensure that English is at the top of the list of languages
  3. Go to Advanced settings
  4. Select English in the "Override for Windows display language"
  5. Hit Save and then restart computer

People app is now displaying in English.

Hope that helps.

196 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated October 27, 2020 Views 49,269 Applies to: