Mail Error 80072F0D for Windows 10

Was setting up mail on Windows 10, adding a gmail account, and it keeps popping up a question whenever I attempt to sync. I have attempted to fix it via powershell, uninstall and reinstalling. 80072f0D is the error popping up as well as 850500...

Would love it to work. Any solutions are welcome, thanks.

[Original title: Mail Error for Windows 10]

 

Question Info


Last updated March 18, 2019 Views 2,608 Applies to:
Please quote the error messages verbatim - the code alone is rarely enough to be able to pinpoint the cause. 0x80072F0D indicates an invalid certification authority, the body that authenticates the certificate used to establish a secure connection to the mail server - and that sounds a bit unlikely for a Gmail account. 
Noel Burgess | Certified Pedant | Claims to know a bit about Windows Live Mail

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Sorry here it is:

Something went wrong...

It looks like there is a problem with the certificate for imap.gmail.com:993:1. If this is not your primary Microsoft account, try deleting the account, then adding it again, otherwise wait a while then try again.

Error Code: 0x80072F0D

Yes, it is a bit odd. I have a internet connection, the account on gmail operates just fine. When I originally added gmail, I was notified on my account, so I know it went through. I have attempted to delete the account, delete and reinstall mail.

I just tried deleting that account and downloading a different email account with gmail and got:

We have a problem downloading messages, make sure you have a connection and your account info is correct, then try again.

Same error code.

I have double checked and we are good. What do you think?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

There are plenty of reports about errors like this, with no apparent unique solution.

  • Ensure that IMAP is enabled in the account settings at mail.google.com.
  • The obvious fault: check the computer's date, time and time zone settings. If they are not reasonably accurate (within a minute or two), a certificate might be rejected as invalid.
  • Another possible cause is the use of third-party anti-virus to scan email, particularly Avast. Turning off Avast's Mail Shield solves the problem. This is not normally risky.
  • There is a slightly trickier possibility: Google has sometimes applied certificates for *.gmail.com instead of the more specific imap.gmail.com, pop.gmail.com and smtp.gmail.com. Not all mail clients recognize the alternative specified, but I doubt that Mail is one of those. Still, you never know, and I don't know how to deal with that if it is.
Noel Burgess | Certified Pedant | Claims to know a bit about Windows Live Mail

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks, it doesn't seem to work still so I might go on without it. Thanks!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.