site uses outdated or unsafe TLS security settings

site uses outdated or unsafe TLS security settings

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi Leon,

Having a more secure connection in an Internet browser requires up to date Operating System. To isolate your concern with Microsoft Edge, we’d like to know the following:

  • The version of your Windows. To know which version of Windows you are using, press Windows + R to open run window, type winver and press Enter.
  • The site you are trying to visit.

For more information about Transport Layer Security (TLS), visit this article.

We’re looking forward to your response.

_________________________

14 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Windows 10 version 1703
Access msn.com, capitolaone.com, and paypal.com are just a few.

6 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The web site sometimes won’t open if temporary files were not cleaned up for a long time. We recommend to clear the cache and cookies of Microsoft Edge. To refresh Microsoft Edge, follow the steps below:

 

  1. Launch Microsoft Edge.
  2. Click the 3 dots () on the top right corner.
  3. Click Settings.
  4. Under “Clear browsing data”, click Choose what to clear.
  5. Tick the checkbox of Browsing history, Cookies and saved website data, Cached data and files, Download History, Form data.
  6. Click Clear.
  7. Wait until all data has been cleared.
  8. Re-launch Microsoft Edge.

 

After doing these steps, open the site again and see what happens.

 

Give us an update once you got a successful result.

_________________________

18 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have already done this several time. What a pain to get all your sites back in play. This never worked. I ran Microsoft defender with complete scan twice and nothing was found. I installed Google Chrome and used it for two days on the same computer and it worked fine. Cell phones worked without a hitch.

I have no idea what happened, but on June 9th everything started working correctly.

I can now get back into MSM.com and all my sites with no issues.

I do post under my real name and hope Microsoft and other companies will provide better security for ALL

19 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Works fine in Chrome.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello there. I know that i am responding late and you may be not interested but just you know. So it seems like your data/time was not up to date so this why you possibly had that error. So it seems like on June 9th your operating system(windows) updated the time and date ,  which helped to solved the problem. Chrome doesnt seem to be affected by this error. Hopefully this will help you or someone in future 

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The last MS10 update I received started the TLS problem.

I have MS10 HOME VERSION V1709 (OS BUILD 16299.125)

I need to know what I must do to solve my problem with using HTTPS.

I have set the internet options of TLS 1.1 & 1,2 only as recommended but this does not solve the problem.

Any help will be appreciated.

Thanks, Ralph Napolillo

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I tried the recomendations to sonabear post on July 6 and it did not work!

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I tried the recomendations to sonabear post on July 6 and it did not work!

Hi Ralph,

Since we have rolled out a lot of Windows 10 updates for the past months, we suggest creating a new thread about the issue for us to effectively assist you.

Regards.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This is a new post as requested.

The last MS10 update I received in the month of December 2017 started the TLS problem.

I have MS10 HOME VERSION V1709 (OS BUILD 16299.125)

I need to know what I must do to solve my problem with using HTTPS.

I have set the internet options of TLS 1.1 & 1,2 only as recommended but this does not solve the problem.

Internet Explorer and Microsoft Edge has the same problem.

I am using goggle explorer to currently get around the problem.

Any help will be appreciated.

Thanks, Ralph Napolillo

 

6 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated September 24, 2020 Views 64,044 Applies to:

Related Forums