Outlook Web Access (OWA) Problems in Edge

I cannot add attachments to email in OWA when using Edge as my browser.  The workaround that some had used when this issue arose using Chrome  -- i.e., adding Silverlight plugin -- does not seem possible with Edge.  This effectively makes OWA useless on Microsoft's own new browser.  Is there a solution?
 

Question Info


Last updated September 9, 2019 Views 45,529 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hello Geoffrey,

Thank you for visiting Microsoft Community and providing us with the detailed description about the issue.

As per the description, I understand that you are experiencing issue with Outlook Web Access problems in Edge in Windows 10.

I certainly understand your concern and will try my best to help you.

I would suggest you to refer to the article given below and check if that helps.

Microsoft Edge

http://windows.microsoft.com/en-us/windows-10/microsoft-edge

For more information:

I would suggest you to refer to the suggestions provided by “Andre Da Costa” replied on January 22, 2015 in the following Microsoft Community link.

Frequently Asked Questions: Windows 10

http://answers.microsoft.com/en-us/insider/wiki/insider_wintp-insider_install/frequently-asked-questions-windows-10/5c0b9368-a9e8-4238-b1e4-45f4b7ed2fb9

I hope this information is helpful.

Please do let us know if you need any further assistance, we will be glad to assist you.

Thank you.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Just installed Win 10 and found exactly the same thing; guess it's another thing to add to the list of real-world user issues... although Edge is nice, IE11 should still be available (was on my update - just typed IE 11 into the search box) - and that still works fine with email attachments.  Not so much of a work-around, just continue using IE for owa (?)

6 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This reply is entirely unresponsive to my question.  Thanks.

228 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Just installed Win 10 and found exactly the same thing; guess it's another thing to add to the list of real-world user issues... although Edge is nice, IE11 should still be available (was on my update - just typed IE 11 into the search box) - and that still works fine with email attachments.  Not so much of a work-around, just continue using IE for owa (?)
Thanks for reply.  Also, Chrome (with Silverlight) and Firefox both allow OWA attachments, FWIW. 

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks; I did try Chrome, but without silverlight, so it didn't work, and as we keep being told that MS is retiring Silverlight I figured I'd try and keep it simple :)

Love how the newest/latest technology doesn't handle what it's predecessor could do, but guess it's early days.  It may be related that with the Exchange 2016 preview recently released, MS has done away with OWA and moving to Outlook on the web (OOW) instead - something else to look forward to...

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Jayant, I don't understand why you would post a reply that is completely irrelevant to the original question.  Can you please address these specific questions:

1. Is there a bug logged with the Edge or Outlook teams that acknowledges this issue?  If so, please provide a link to the bug so that it can be tracked. 

2. Is there any known work around for this issue?  Obviously we can open outlook web mail in IE11 but is there anything we can do in Edge?

Thanks,

Jeff

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have tried the IE11, but my Outlook Web App is in light version mode and I can't change it.  Does anyone else have a possible solution?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Can you access the OWA account using Internet Explorer instead of Edge?  See this tutorial => http://www.tenforums.com/tutorials/5619-microsoft-edge-open-website-internet-explorer.html [ignore #3]

--
~Robear Dyer (PA Bear)
Microsoft MVP (Windows Client) since October 2002

8 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey Simon, in IE11 if you add the site to your "Compatibility view settings" list then it should enable the full version instead of the light weight version.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Jayant,

Adding attachments to an email using Outlook Web Application does not work on Microsoft Edge. How do I fix this?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.