Microsoft edge not working - EMODEL.dll

windows 10 edge browser is not working , had upgraded to windows 10 yesterday

Every time typing url in address bar leaves a blank page and site is not shown

even not able to update default search as the add button is

Even new tab is not is not opening - but randomly opens after 10+ ctl+t - please provde fix to reinstall Microsoft edge

seeing this error in event log

Faulting application name: microsoftedgecp.exe, version: 11.0.10240.16384, time stamp: 0x559f3853
Faulting module name: EMODEL.dll, version: 11.0.10240.16397, time stamp: 0x55af11c4
Exception code: 0xc0000409
Fault offset: 0x0000000000112cb3
Faulting process id: 0x244c
Faulting application start time: 0x01d0cacfd889ff6d
Faulting application path: C:\Windows\SystemApps\Microsoft.MicrosoftEdge_8wekyb3d8bbwe\microsoftedgecp.exe
Faulting module path: C:\Windows\SystemApps\Microsoft.MicrosoftEdge_8wekyb3d8bbwe\EMODEL.dll
Report Id: f4ca02f1-202d-4243-902b-1653598f2980
Faulting package full name: Microsoft.MicrosoftEdge_20.10240.16384.0_neutral__8wekyb3d8bbwe
Faulting package-relative application ID: MicrosoftEdge

Also running sfc this does not solve the issue - sfc /scannow 

 

Question Info


Last updated May 16, 2019 Views 18,077 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Edge on my machine won't start on my profile.

All faith in Microsoft's Edge browser is gone.   It worked and then suddenly with no provocation just stopped working. As in it will not load no if anyone tells me to click on the three dots then I will be replying using only capital letters.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Exactly Same issue happens to my machine.

> upgraded from previous windows version

> on launch, Edge browser does not work at all, putting url does nothing but to let cursor blink hourglass mode.

> on event viewer, says "EMODEL.dll" has some sorta problem, from microsoftedgecp.exe

> command line input "sfc /scannnow" does not solve the problem

I hope someone with MS help with this issue or

I'd just go for IE11 or Chrome.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

If you disabled the Windows Firewall Service it won't work. (eg. meaning, you set the services startup setting to "disabled" rather than "automatic" - and not just turned off firewall features)

To quickly verify:

--> Hit Windows Key + R

--> type "services.msc" & press enter

--> Sort by name, locate, & right click on the Windows Firewall service

--> Choose the "properties" option to make sure "startup type = automatic"

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Right....  After struggling so long, the solution to my problem ended up something people would not dream about. Actually two issues fixed in one action. Associated file icons and Microsoft Edge not loading.

First issue is about missing file and shortcut icons on Microsoft Office. I upgraded from Windows 7 to Windows 10.  Windows 10 moved the old C:\Windows\Installer directory to C:\Windows.old\Windows\Installer.  The registry points to files within the Installer directory to get it's file icons. Only recently installed applications had their files stored in C:\Windows\Installer.

I've since fixed-up the C:\Windows\Installer directory and all the Office icons have come back.  Every single one.  Also, being able to change the configuration of installed desktop applications and being able to uninstall desktop applications is working again.

Regarding Microsoft Edge, even the unfinished Microsoft Edge browser has begun to work again as that was broken. Same thing.   It would start and instantly stop pointing at EMODEL.dll being the culprit.

Also, are the ACL's for and contents of C:\Windows\Installer correct?

I'm guessing after a Windows 10 upgrade, a month later C:\Windows.old may be automatically erased so maybe take a back-up of C:\Windows.old right now before you do anything else. Before the Windows 10 eradicated files you may need to fix a Windows 10 problem after an upgrade.

I did make sure that the contents in C:\Windows\Installer were not replaced with contents from C:\Windows.old\Windows\Installer. It's been a while since I did this fix-up and everything is still working. I really hate it when the fault actually lies somewhere else.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Same issue.  Works fine in an InPrivate Tab.

Any help is appreciated.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I've found the right solution for this:

0. Delete the folder "Microsoft.MicrosoftEdge_8wekyb3d8bbwe" in your user profile directory          

    C:\Users\%Userprofilename%\AppData\AppData\Local\Packages\Microsoft.MicrosoftEdge_8wekyb3d8bbwe
1. Open a powershell with admin permissions (run as administrator)
2. Find the installation folder with the following command:
    Get-AppxPackage *edge* | fl name,*location*
3. Navigate to the installation folder (see location from command above)
    set-location C:\Windows\SystemApps\Microsoft.MicrosoftEdge_8wekyb3d8bbwe
4. Repair the Edge browser
    Add-AppxPackage -DisableDevelopmentMode -Register ".\appxmanifest.xml"

55 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

FWIW, you can replace steps 2&3 with:

Set-Location(Get-AppxPackageMicrosoft.MicrosoftEdge).InstallLocation

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thank you Jogibaer1!  Where did you find that!  Yes, it worked for me.  And, yes - I had tried everything above that.  Makes me wonder what else is broken that needs fixed!  Good job!  Thank you for sharing!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Just how do you propose we open the "..." on the right hand side when the window does not stay open for more than a millisecond?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Edge on my machine won't start on my profile.

All faith in Microsoft's Edge browser is gone.   It worked and then suddenly with no provocation just stopped working. As in it will not load no if anyone tells me to click on the three dots then I will be replying using only capital letters.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.