Microsoft Edge blocking cookies Windows 10

Microsoft Edge(windows 10) is completely blocking cookies... as an example I cannot log in to my Microsoft account, every time i go to the website it says this...

"

Microsoft account
 
Cookies must be allowed

Your browser is currently set to block cookies. Your browser must allow cookies before you can use a Microsoft account.

Cookies are small text files stored on your computer that tell Microsoft sites and services when you're signed in. To learn how to allow cookies, see online help in your web browser."

Also because of this I cannot sign in to the store, neither download apps, neither go through the settings/accounts/your account/sign in with Microsoft account instead. It is really annoying. 

Google chrome is not blocking cookies.

Mozilla is not blocking cookies.

IE is not blocking cookies.

 

Question Info


Last updated November 14, 2018 Views 25,477 Applies to:
Answer

This issue may have been caused by the Privacy settings set up to your Microsoft Edge browser.

Modifying the Privacy settings of your browser can help. To do this, refer to the steps below:

  1. Press Windows key + R on your keyboard.
  2. On the run command box, type inetcpl.cpl, and then hit Enter.
  3. Choose Privacy tab.
  4. Click Advanced.

  5. Under Advanced Privacy Settings window, select Accept under First-party and Third-party Cookies.

  6. Place a check mark under Always allow session cookies.
  7. Click OK.
  8. Go back to Privacy tab, select Sites. type in the specific website that you are trying to visit, and then click the Allow button.

  9. Click OK.
  10. Click Apply and then hit OK.

Should you need further assistance, feel free to get back to us.

25 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.