Microsoft Edge 'Blank Screen and ClosIng'

Since upgrading Win 10  with 'Media creation Tool' (as I could not access Store/Photos and a number of Apps...now fixed) Edge opens to a blank screen and closes after about 5 secs (Screen shot attached) I have trawled the Inernet for fixes and tried about everything there is  ie

  • sfc /scannow
  • deleting Edge folder in APPDATA/LOCAL/PACKAGES and applying the string thru'Powershell (Get-AppXPackage -AllUsers -Name Microsoft.MicrosoftEdge | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml" –Verbose}
  • running Reimage Repair
  • Checking Registry values
  • etc etc

The last resort is a guess a 'clean install' , I am using Firefox in the interim and may stick with it as Mozilla seemed to have vastly improved the load up/search speed.

Any pointers appreciated as just don't like a small elementof the OS not performing

Thanks in advance

LH

SCREENSHOT

***Post moved by the moderator to the appropriate forum category.***

 
Question Info

Last updated July 4, 2018 Views 4,051 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi Len,

There may be a few reasons why Edge is opening as blank and closes after a few seconds, you can utilize the following troubleshooting suggestion to arrive to a resolution:

Steps to reset the Edge browser

  1. Open Microsoft Edge.
  2. Press ALT, CTRL and DELETE to open Task Manager.
  3. Right click on Microsoft Edge in the task manager and select Go to detail.
  4. Right click MicrosoftEdgeCP.exe and select End task.
  5. Repeat the process for all MicrosoftEdgeCP.exe.

If that doesn't do the trick then you can consider creating a new user account in your Windows computer and see if this would resolve the issue. Begin creating a new user profile by clicking this link: Create a local user or administrator account in Windows 10.

Please update us of the result for us to help you further.

Regards.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Jesrael, Thanks for that ....the 'Reset' option doesn't work as the ,exe files drop off Task Manager anyway as Edge only stays open for about 5 seconds so when it closes the MicrosoftEdgeCP.exe file disappears.

The add user account does not work either  , this was one of the 'etc' fixes I had tried

Cheers

Len

Did this solve your problem?

Sorry this didn't help.

Same just started happening to me today.

Edge opens, with a Blank page (normally my home page appears), then 5 seconds later, edge closes.

It also disappears from Task manager.

Installed the Creators update last week..... Well done Microsoft, do you ever do anything right?

P.S. Microsoft, while your at it, get your finger out and fix the stupid Window Defender icon which doesn't recognise Zonealarms as a firewall.

Note to self, never install these pathetic Microsoft gimmicky updates, they break more things than they fix

Did this solve your problem?

Sorry this didn't help.

having the same issue too. it sucks to know that an update which is supposed to make the windows OS run better is messing up. microsoft please check your stuff again. i love edge and it hurts me a lot for not being able to use it. please work at it and make it function again. thanks.

Did this solve your problem?

Sorry this didn't help.

I don't think it's caused by the Creators update. I'm running CU already from the launching some months ago. 

Just two days ago Edge started to fail as described by the topic starter.

Anyhow, whatever the cause is, it's very annoying! 

Did this solve your problem?

Sorry this didn't help.

Guess this one has run it's course, will continue to use Firefox (just as fast) until either Microsoft come up with a solution or an update to fix this

Thanks guys for th input

Len

Did this solve your problem?

Sorry this didn't help.

Len,

I resolved the issue.......................... by rolling back to the "previous version of Windows 10".... i.e. pre-this-buggy-creators version

10 minutes later, Edge working perfectly fine.

When Microsoft turn a blind eye to these posts, then you end up taking matters into your own hands.

Moral of the story, don't update anything Version wise, until it's been out for at least a year

Did this solve your problem?

Sorry this didn't help.

Hi,

I have this problem as well and running chrome at the moment. How do I switch back to the previous version? I'm not very techie and I did try a "restore" date, but it didn't work. Can you walk me through this change?

Did this solve your problem?

Sorry this didn't help.

Hi Frank,


If you'd like to go back to the previous version of Windows, you may go to Settings > Update & security > Recovery. This will keep your personal files, but it'll remove apps and drivers installed after the upgrade, as well as any changes you made to settings. For more information, kindly check this article. Go through the section: Go back to your previous version of Windows.

Do let us know should you need further assistance.

Did this solve your problem?

Sorry this didn't help.

Tried it and it didn't work either. Maybe because I notify Microsoft who decided to download a complete package on ISO, which didn't work either. Wasted about 6 hours of my life. Anyway, I am getting to know Chrome much better and actually starting to like it better than Edge. Loser here? Microsoft.

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.