Q: Edge not running on Creator's Update

Split from this thread.

I have somewhat if an analogous problem.

I downloaded the Creator's Update and installed it. I experienced a similar problem as Edge but with the Solitaire collection. I click on the Start Menu icon, the Start Menu program list or the program in the Windows store and a flash would appear as though Solitaire was starting and then immediately disappear. This problem occurred on 3 of 4 ids that I have on the PC. 4th id was not tested. Two long support chats with MS and learned that if a new account was created then the problem was not associated with the new accounts. After the second chat, a resolution was tried and it messed up  my id. I said forget it and reinstalled Win 10 with no save of the existing system. The second chat person indicated that she would open a trouble ticket with the XBOX support staff in Microsoft.

After the reinstall, recreate 4 ids, reinstall software that I use I have this problem. The Solitaire problem no longer exists.

Edge works on 2 of the 4 ids. On the other 2 ids, Edge briefly starts, window frame displays and then Edge closes.  The pattern is the same on both ids. I started IE and that works as expected.

So far, the few problems that I have encountered I have resolved from my own experience or contact with the vendor. I have only a Team Viewer problem unresolved but I will have to wait till Monday to talk to the vendor as their WEB site is down.

In my case, I do not think the creation of a new account would assist with a resolution.  But I am open to any suggestions. 



****Post split by the forum moderator from a thread wit different issue.****



I ran the system file checker tool and had no integrity violations.  My edge still does not work after the 1703 update.


I fixed it using this method

Follow the instruction provided below and check.

  1. Boot your system into safe mode.

  2. Navigate to the location:


  3. Delete everything in this folder including the folder.

  4. Restart your system in normal mode.

  5. Type Windows Powershell in search box.

  6. Right click on Windows Powershell and select Run as administrator.

  7. Copy and paste the following command.

    Get-AppXPackage -AllUsers -Name Microsoft.MicrosoftEdge | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml" –Verbose}

  8. If the process was completed successfully, you would see a message similar to this one:

  9. Restart your system and it should work.

Did this solve your problem?

Sorry this didn't help.

170 people were helped by this reply

Question Info

Views: 25,545 Last updated: March 10, 2018 Applies to: