You do not have permission to access \\PC_NAME contact your network administrator to request access

***Modify title from: Permissions***

Hello,

I have a network configured as a workgroup.  All 9 systems are Windows 10.  I'm using one as a file server.  My issue is I have shared the C drive on this file server giving everyone full control but from the workstations when I click onto Network and double click onto the file server name (Server) I receive the below error:

you do not have permission to access \\Server Contact your network administrator to request access

Please advise!

 

Question Info


Last updated April 1, 2020 Views 71,050 Applies to:
Answer
Answer

Hi DonnaWhite95,

Thank you for writing to Microsoft Community Forums.

Could you please help me with the below questions:

  • Which version of Windows you are using on all the computers? (To check, type : winver in start menu and hit enter.)

  • As you have mentioned about File server, is it a Server or a normal Windows 10 build installed on it?

Meanwhile, please follow the troubleshooting steps as mentioned below:

Method 1: Start the Network related services.

  1. Press Windows and R key together on your Keyboard.

  2. Type Services.msc and it enter.

  3. Search for the following services.

  • Function Discovery Provider Host (FDPHost)

  • Function Discovery Resource Publication (FDResPub)

  • Network Connections (NetMan)

  • UPnP Device Host (UPnPHost)

  • Peer Name Resolution Protocol (PNRPSvc)

  • Peer Networking Grouping (P2PSvc)

  • Peer Networking Identity Manager (P2PIMSvc)

 

4. Reboot the device and check the Network tab again.

Method 2: Provide permissions through settings.

  1. Go to Control panel > Click on network and internet > Click on Network and sharing.

  2. Click on Change advance sharing settings on the left pane.

  3. Select the options

  • Turn on network discovery.

  • Turn on file and printer sharing.

  • Allow windows to manage home group connection(recommended).

  • Turn on sharing so anyone with network access can read and write files in the public folders.

  • Use 128-bit encryption to help protect files sharing connections (recommended).

  • Turn off password protected sharing.

4.  Click on Save changes.

Method 3: Turn on SMB feature.

  1. Press Windows and R key together on your Keyboard.
  2. Type appwiz.cpl and hit enter.
  3. Click on 'Turn Windows Features On or Off' (upper left side of pane).
  4. In the popup scroll down to SMB 1.0/CIFS File Sharing Support.
  5. Check the option and click on Ok.

              

Now restart both the machines and check if it is working now.

If the PC you are trying to share the files from is Server, then I would suggest you to post the query in IT Pro TechNet forums, where we have support professionals, who are well equipped with the knowledge on issues with Servers. Please let us know the results.

Hope it helps.

Roohi Taj S 

Microsoft Community - Moderator

11 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer
Answer

This is such a common problem, but nobody at Microsoft seems to know how to fix it.

My problem was inability to access the Users/username/documents folder on my wife's laptop for read-only access from my desktop.  The solution was to select the Users folder and specify Properties/Sharing then select Everybody with Read permission. The message "This may take several minutes" means it works.

23 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.