WSL is broken

In Windows 10 Pro Insider 20190.1000 whenever I try installing a distro from MS Store, it downloads fine, but after launch it says "Installing, please wait" then fails with the following error message:

WslRegisterDistribution failed with error: 0x800706be
Error: 0x800706be The remote procedure call failed.

I tried it with Ubuntu and with Debian, neither of them work.

I tried disabling the WSL feature from "Turn Windows features on or off", rebooting, turning it back on, rebooting again, trying with both distros again, and the same error happened again with both.

This issue is driving me nuts as I really need a Linux-only CLI tool right now, and I can't do anything to get it working.\

<Moved from Windows 10 forum>

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

I think is an insider problem, do yo are in a insider preview version? 20190?

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I did solve the problem.  basically I had a windows 10 Home, on which I was running ubuntu with no problem. then I decided to install windows 10 home insider preview version 20185, and this made running ubuntu impossible. I upgraded to windows 10 Prof. Insider preview version 20190, I still was not able to run ubuntu but this time the error message was different: 0x800706BE . I found out from posts on the web that resetting a number of related services, while clearing out your temporary folder, eliminates this error. you can do this by making the following .bat file on your desktop and running from there:

net stop wuauserv

net stop Cryptsvc

ren %windir%\SoftwareDistribution sdold.old

ren %windir%\system32\catroot2 crt2old.old

net start wuauserv

net start Cryptsvc

This solved the problem and now I can ubuntu just fine

4 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

im having this same problem 

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi, try this command from cmd "wsl.exe --update"

15 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

this issue persists in build 20197 and with wsl kernel 4.19.128

suggested solutions do not resolve the issue.

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

WslRegisterDistribution failed with error: 0x800706be

Error: 0x800706be The remote procedure call failed.

I am having same issue Build 20201.rs_prerelease.200822-1922

I have tried both the solutions I found here with no change. Also tried removing and reinstalling WSL. No luck... 

Still poking around. 


Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi all,

I finally got this resolved after following these steps:

(from https://github.com/docker/for-win/issues/7208)

  • Uninstall Docker and WSL 2 kernel.
  • Go to the Control Panel -> Programs -> Turn Windows features on or off
  • Uncheck the following: Containers, Hyper-V, Windows Subsystem for Linux
  • Restart the system
  • Install Docker without the WSL2 enabled/checked in the first screen
  • Go to the Control Panel -> Programs -> Turn Windows features on or off
  • Turn on/check the Windows Subsystem for Linux
  • Restart the system.
  • Do not install the WSL2 Kernel when reinstalling Docker.

I was not able to launch the Ubuntu WSL initially (got the same error messages in the first post), I then ran "wsl --update" and was able to launch the Ubuntu WSL and got Docker started running again.

My system now has wsl kernel 4.19.128 and Build 20201.rs_prerelease.200822-1922, and the default wsl version is now version 2.

Hope this helps. Cheers.

3 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I have the same issue

Windows Insider Build 2004 20201.1000

installed on 27-Aug-2020

and could not bring Ubuntu 20.04 in

Before that my Ubuntu 18.04 WSL2 

stopped working.

Had been working flawlessly for many months

since moved to WSL2.

Not-working symptoms were: could not

ssh to remote systems.

Then finally gave up to start.

Removed Ubuntu 18.04, downloaded

20.04 and now cannot start it for the first time

, and getting this 0x800706be error

WslRegisterDistribution.

Also applied all George Apostopuolos1's tricks

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi all,

I finally got this resolved after following these steps:

(from https://github.com/docker/for-win/issues/7208)

  • Uninstall Docker and WSL 2 kernel.
  • Go to the Control Panel -> Programs -> Turn Windows features on or off
  • Uncheck the following: Containers, Hyper-V, Windows Subsystem for Linux
  • Restart the system
  • Install Docker without the WSL2 enabled/checked in the first screen
  • Go to the Control Panel -> Programs -> Turn Windows features on or off
  • Turn on/check the Windows Subsystem for Linux
  • Restart the system.
  • Do not install the WSL2 Kernel when reinstalling Docker.

I was not able to launch the Ubuntu WSL initially (got the same error messages in the first post), I then ran "wsl --update" and was able to launch the Ubuntu WSL and got Docker started running again.

My system now has wsl kernel 4.19.128 and Build 20201.rs_prerelease.200822-1922, and the default wsl version is now version 2.

Hope this helps. Cheers.

I can confirm that KenNg2014's solution works. I have wsl working again. I didn't intend on installing docker initially, but I have been meaning to give it a try so what the heck... I will continue  trying to find other methods of fixing on another machine I have with this issue.  

Cheers to all

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

hmm I solved this with "wsl.exe --update" and "wsl.exe --shutdown"

3 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated March 29, 2021 Views 4,928 Applies to: