Windows Writing temporary folders and files to External Drives. How to stop?

For some reason, Windows is writing temporary folders and files onto external drives, and other partitions. Generally the largest available drive plugged in.

Normally this would be fine. In my case, however, since I have Mac formatted external drives (that I use MacDrive 8 to access), it corrupts these drives, including my Mac boot partition.

Basically I need to stop Windows from writing these files anywhere, other than to the Windows Partition.

After looking around a bit on the forums, I may have found a similar problem to it at this thread:

http://social.answers.microsoft.com/Forums/en-US/mseupdate/thread/d4e9849e-7bd1-4580-aa43-695321a8f10f

Third post from the bottom where he writes :



"[...] I was using the 1TB drive and suddenly the whole system slowed down and access to the 1TB drive was very sluggish.  The system would not let me eject the drive.

I rebooted and found some MSE files/folders on the drive, one was (from memory) a "redir" file and the other was a folder called 4efc85e3bb644236da736f0e22bfd0 that contained a number of files [...]"



Almost the exact same thing happened to me, which is what causes the drives to become corrupt.

  • The drive slows down, and takes roughly 10 minutes or more to gain access to the drive.
  • There were new files and folders, some similar to "4efc85e3bb644236da736f0e22bfd0" 

 Again, I basically need to stop windows from writing these temporary files to external drives and other partitions. Why can't it write them to my Windows partition by default? Any way to change this?



Other Info : Macbook (Pre Unibody) 2gb ram, 2.13ghz core 2 duo, GeForce 9400M

                  Windows 7 Ultimate 32 bit (64 bit has the same problem as well)

                  Again, using MacDrive 8 to access the HFS+ formatted drives.



Any info on how to change/fix this will be GREATLY appreciated. I'm half tempted to just remove windows all together.

 

 

Answer
Answer

Hi XtylerwallX,

 

I would suggest you to change the Virtual Memory settings. To do this, follow the steps below:

 

1.   Click Start, right click on  Computer and select Properties

 

2.   Now from the left pane select Advanced system settingsand then click Settingsunder Performance

 

3.   Go to  Advanced tab on Performance Options Window

 

4.   Under Virtual Memory Section > Click on Change Button

 

5.   Uncheck the option “Automatically manage paging file size for all the drives” and then set the drive you want to use paging for

 

Thanks and Regards
Praseetha K
Microsoft Answers Support Engineer


If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated December 15, 2020 Views 2,738 Applies to: