Windows Update waking computer in the middle of the night. [I'm pissed off]

Hello All,

This thread might get deleted by Microsoft because it goes against their REALLY ANNOYING update policies.

So, the date is 12 March 2020, time, around 2 AM. I put my computer to sleep and go to bed... a few minutes after that, my computer automatically wakes up (I have a steering wheel plugged into it, which auto-calibrates when windows wakes up and it is quite noisy). So I put it to sleep again and went to bed again... Until it woke me up 2 hours after that... I went to Event Viewer, found out what was causing it... Windows Update, as it couldn't get any worse than it already is. A few months ago, I've spoken to Windows Support, which failed to cooperate to help me stop Windows Updates, even though I explained that their new update breaks a software I am using, so I refuse to update and I understand the security issues that come with that, but they kindly explained that it is "not possible" to turn off updates... And now my computer wakes me up with those pesky updates? That was the last straw.

What I did:
1. Deleted all services related to windows update (orchestrator, assistant, update, medic service, all of them)
2. Deleted all of the task scheduled to WAKE MY PC UP WITHOUT MY PERMISSION.
I've done it from the registry editor:
"HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Services" - Delete everything related to windows update
"HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Schedule" - Delete everything related to windows update
(might be a bit confusing at first, just go through the registry files, you can see the name of the task/service there.)

Dear Microsoft,

I am using your OS, but my computer is still MY COMPUTER, please do not give me "permission denied" signs like they would stop a programmer. I paid for it, so please chill out with the permissions, I should have full permissions over you. Like I explained to your support staff, just make an "I am not an idiot" check-mark in your options that allow you to make modifications to your windows without anything trying to stop you.

Even if you patch the registry permissions or something, I WILL hack the living hell out of your OS with Linux to stop them again. So please, spare us all the sanity loss and don't do it.

Best regards,
Someone who just got woken up by your impudence to wake my PC up.

Hit the windows key, type services, click on it at the top, scroll way down to Windows Update, click on it and in the middle of the pop up change the Startup type to Manual.  Then you can do your updates when you are not busy.  You will need to check the updates every day to make sure you are up to date.

-----------
If this answers your question - Then mark it so. Then others may find it.
---------------
Around computers
since 1952
lacrumb
I have it disabled from there, not just set to manual. The Update Medic service just starts it up and wakes my PC up whenever it likes.
Windows Support Staff Slayer,
Don't reply to me if you are from India or Vietnam

I had this same problem, this is what i deal with Win 10 Home

It might be more easier with Pro.. you have more access to the MSC consoles that are not available in Home

Like Group Policy Editing where you can change some template settings on Windows update components 

In another post that I made I really was upset and posted about how Win home 10 Ruined a Data recovery that I had done that took over 6 hours.. Come back only to find my PC restarted and I lost all the scan results.

Had to start over............

1. Is there any reason you can't do a "full" shutdown of your system when you are done for the day instead of using "Sleep"?

2. Even the normal shutdown option can be an issue as the computer does not totally shutdown. You would have to shut off "Fast Startup" in the power options to allow the computer to totally shutdown or you could create a desktop shortcut to execute the full shutdown command.

3. The other thing to check is to see if you internet adapter has "Wake on LAN" set to "ON". Shut that off and see if that helps.

JohnD

1. I don't want to do a "full" shutdown, because I have a lot of things set up, opened and so on and I don't want to spend the time automating it, when I can just put my PC to sleep.

2. Fast Startup is off, as it caused issues for me.

3.Wake on LAN is off, PC gets waken up by a task from the task scheduler, not from a LAN request for the update.

- I just restarted my PC for the first time since I posted seems like Microsoft put some kind of auto install for the cruddy windows update medic service, had to delete it again... 

Dear Microsoft, PLEASE, some of us DO NOT want your updates, we don't care about what "security" thingies you add or whatever... We just want to be in control of OUR operating system... 

Windows Support Staff Slayer,
Don't reply to me if you are from India or Vietnam

Why can you not get all those things started up when you start the computer.

ie if you can not start things when you start your computer then you do not know how to use your computer.

If you want apps or programs to start when you turn on the computer put them in Task Manager Startup.

-----------
If this answers your question - Then mark it so. Then others may find it.
---------------
Around computers
since 1952
lacrumb

That's logical, but it is not that easy. I have Software pages, some documents that I need to remember till which page & line I am currently.

It's not as easy as to put them in the system startup... even if they start I will still lose my progress. I don't want to go around and save everything, write down the last page and line I translated somewhere else and so on... I love the windows sleep function, it would be great if it just works as intended without waking my PC up to install updates I don't want.

Now I am tinkering with the group policies and I hope that solves my issue with the updates once and for all...

I want only one thing... and it is called "freedom of choice" I don't like to be forced to do something that would affect my system... "If it ain't broke, don't fix it". I am sure you are way more experienced than me and I hope you understand my point of view here.... 

I would just love a "leave me alone, I'm not an idiot" button in the settings, which removes all of the "access denied" **** and automatic downloads and installs of updates, just a clean, normal experience like Windows XP, is that so hard ?

Windows Support Staff Slayer,
Don't reply to me if you are from India or Vietnam

use group policy editor, to disable wakeup and related windows updates.

I am already using that GPE for many purposes.

 
I am a regular CONTRIBUTOR on docs.micrsosoft.com Asus Laptop R542UQ-DM153-Intel_i5-7200u_Nvidia_940mx_2GBvram-16GBram-2TBHDD_2TBHDD_250GB_M.2SSD_Windows10_Enter_2004_64bit_19042.572

You did not mention whether you had Windows 10 Home or Pro but I assume it is Home. There are several entries in the Scheduled Tasks for Windows Update that you might want to consider disabling or turning off "Wake the computer to run this task".

Look at the 3 top scheduled tasks under the WindowsUpdate section. They all have "Wake the computer to run this task". I don't recall disable them myself. Since I have Windows 10 Pro, I assume these were disabled by some change I made in the Group Policy Editor. Shut those off and see if it helps.

JohnD

Thanks to JohnD for the solution, I should have checked this thread a long time ago, but I did use Group Policies at the end. I just hope Microsoft does not patch that too...

P.S.- I am also using Pro.

Windows Support Staff Slayer,
Don't reply to me if you are from India or Vietnam
 
 

Discussion Info


Last updated October 12, 2020 Views 452 Applies to: