Windows Update Deleted my Sound Driver

During the last update (week of 5/8/2017, when I restarted my computer after installing the updates, the sound drivers for my AMD High Definition Audio Device were missing.  I updated my graphics card driver through the manufacturer website, which fixed the problem.  However, when I restarted my computer again to "update my computer with the changes", same problem, the device was missing.

When I install the drivers, it sets the AMD High Definition Audio Device as the default, so when I restart, I know it is my default.  I have disabled the Realtek Audio device, and I'm getting ready to uninstall the driver altogether in hopes that my AMD settings will "stick" this time. 

Is there a way to keep this from happening?  How do I permanently set the AMD to default so that it isn't overwritten?

***Post moved to the appropriate forum category by the moderator.***

 

Question Info


Last updated October 7, 2019 Views 5,684 Applies to:

Hello,

When you have installed the driver and had the AMD High Definition Audio Device set as the default, the update installed on the PC caused some changes in the system settings. To set the AMD as the default device, you may follow the steps provided below.

  1. Right-click on the Windows icon; then select Control Panel.
  2. Click Hardware and Sound.
  3. Under Sound, select Manage audio devices; then select AMD High Definition Audio Device.
  4. Click Properties; on the lower left corner, toggle the Device usage to Use this device (enabled).
  5. Select OK.
  6. Going back to the Sound pop-up window, click Set Default; then select OK.

Let us know if the above instructions help.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Vanessa,

Thank you for your reply.  However, this was not my solution. When I reinstalled the AMD drivers on my computer, it set the AMD HD Audio Device as the default. It is almost like the Realtek devices don't recognize my monitor has speakers, or that my graphics card also is my audio card.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Since the issue happened after installing the update, we recommend that you follow the steps provided below.

Method 1

Run the Windows Update Troubleshooter. Running the automated troubleshooter will help you resolve misbehavior caused by the update installed. You may install the automated troubleshooter here.

Method 2

Run the System File Checker (SFC) tool. SFC will help you scan your system files and to repair missing or corrupted system files since you have mentioned that the sound drivers for the AMD High Definition Audio Device were missing. Kindly check the link below for the steps.

Use the System File Checker tool to repair missing or corrupted system files

Method 3

If SFC was not able to detect any corruption in the system file, we recommend that you run the DISM or System Update Readiness tool. DISM will help you fix some Windows corruption errors caused by the update you have installed. The following article will provide you the instructions.

Fix Windows Update errors by using the DISM or System Update Readiness tool

Let us know if the solution resolves the issue.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I had the same issue. My solution was to restore the system to a point before the update. I then used the group policy command (gpedit.msc) to open the Local Group Policy Editor . I then expanded Administrative Templates then Windows Components and left clicked Windows Update. Double click "Configure Automatic Updates" click the enable button and select option 2 "Notify for Download and Auto Install" and click Apply. This will prevent updates from installing. I also enabled "Do not display Update and Shutdown" option. I also enabled "Do not connect to any Windows Update Internet Locations".

My system is now running perfectly with all audio devices present. When I go to settings/windows update the available updates are displayed but they will not be installed.

Microsoft no longer control which Windows 10 updates they can force upon me. Windows Defender still updates as normal.

I hope this information is of assistance to you.

12 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.