Windows Defender error: "Some History Items could not be displayed"

I've been having a problem with Defender since installing Windows 7 Professional.

For some reason, it will not run it's regular scheduled daily scan and is always telling me it needs to scan.  When I broke down and ran the scan manually (quick-scan) it stopped with an error:

"Some history items could not be displayed. Please wait a few minutes and try again. If that doesn't work clear the history and then try again.  Error Code: 0x8050800d"

I waited and tried again and the same thing.  Then I tried a full scan and went to bed.  When I got up, it appears to have finished and showed 2 "harmful or potentially unwanted software."

The two programs it showed were installation files for RealVNC and TightVNC.  TightVNC is part of an ISO file for an Ultimate Boot CD for Windows. Both are valid, and perfectly harmless (if you use them right) programs that Defender has always seemed to have a problem with.

I selected "Allow" and clicked "Apply Actions" and it started to do something .  I don't know what exactly, but a progress bar started, made it about 10% of the way across and then the same above error appeared.  Even though the "Apply Actions" button had a shield on it indicating that it would need elevated rights, I never have received a UAC prompt for this.

I have checked the history page on Windows Defender, and I cannot see the history.  It tells me they are hidden to protect user privacy, but when I click the view button, the message goes away and there is nothing shown.

I have rebooted and tried scanning (the full scan that pulled up the above two items) and still receive the error.

I found other posts in the Vista forums that indicate the exact same error that suggest running SFC /scannow from an elevated command prompt.  I've done this and it did not find any problems.

So that's where I stand on this issue.  Nothing I've done seems to have worked to fix this problem.  I really liked having Defender running when I used Vista, even if I never really needed it. :)  I would really like to solve this problem and get it working properly again.


Eric the Grey
Eric the Grey
 

Question Info


Last updated October 27, 2018 Views 7,326 Applies to:
Answer
Thanks for the reply Umesh.  I found my answer.

I checked Services and Defender is set to startup automatically (delayed). No problem there.

I had it do a checkdisk, and it didn't seem to do anything (or it was too fast for me to catch).

I didn't get to creating characters because I thought to look at something first, therein lies the answer:

In C:\ProgramData\Microsoft\ there are a lot of folders with paddle lock icons on them.  This, I believe is because my installation is an upgrade, rather than a fresh install, and some of these directories are left over from Vista, and the permissions were all messed up.

So I went through the Windows Defender directory structure and manually added "Administrator" and "Everyone" to the folders.  I gave Administrator full rights of course, and Everyone read execute and list but not full control.

This has solved my problems with this particular error.  Scans since then have completed normally, and I was able to tell it that these two programs were Ok to leave. :p



Eric the Grey
Eric the Grey
Eric the Grey

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.