Windows 7 update installer fails with error 0xc8000222

When I run Windows6.1-KB982018-v3-x64.msu it immediately fails with error 0xc8000222.  The description of the update is here:

The purpose of the update is to fix this very problem with windows update.  In my case, it's due to changing my hard drive from one with 512byte sectors to 4K sectors.  This causes windows update to fail.  As you can see, it's a catch-22 because if windows update fails in the first place, how the heck is another windows update supposed to fix the problem, since it fails the same way?

I fixed the problem by simply renaming edb.log and rebooting.  The OS then deleted the renamed version and created a new version.  Problem solved.  Now I can apply windows updates and I stop seeing the error from ESENT in Event Viewer:
wuaueng.dll (1076) SUS20ClientDataStore: Error -1811 (0xfffff8ed) occurred while opening logfile C:\Windows\SoftwareDistribution\DataStore\Logs\edb.log.

I think instead of asking the customer questions about anti-virus software, etc, it would have been better to focus on the problem.  This could have included examining the errors in Event Viewer, logs and cloning back to a drive with true 512-byte sectors.  But thanks for your efforts, it's appreciated.

342 people found this reply helpful


Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.


Question Info

Last updated May 31, 2021 Views 38,699 Applies to: