Windows 7 update error 800728F8

Hi everyone,

I know there are many threads out there and I have looked at many of them and tried them all, but since installing Windows 7 on a Dell OptiPlex GX620 for school purposes, I have had the above mentioned error occur through everything, along with the dreaded certificate not recognized on every web page.  I have done the following:

1. checked correct local date & time setting in windows as well as in bios

2. added Microsoft update websites in trusted sites.

3. downloaded & installed system update readiness tool for windows7 32 and 64 bit. (I have tried both versions)

4.unchecked server certificate revocation

5. downloaded current root certificate (GTE)

6. registered windows.dll

regsvr32 softpub.dll /s

regsvr32 wintrust.dll /s

regsvr32 initpki.dll /s

regsvr32 mssip32.dll /s

I have done all of these things, yet I am still getting the error.  Any more insight would be greatly appreciated.  I am open to trying anything at this point. 

 
Question Info

Last updated August 17, 2018 Views 2,769 Applies to:
Answer

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.