windows 7 problem not shutdown

Hello sir / Mam 

you don't have permission to shutdown and restart this computer windows 7

 

Question Info


Last updated February 22, 2020 Views 6,683 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hello sir / Mam 

you don't have permission to shutdown and restart this computer windows 7

Is it a virus or Window 7 issue. Even we are facing it

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello Team, 

I am facing the same issue with my windows 7 and getting below error when i shutdown and restart the system.. 

"You don't have permission to shutdown and restart this computer"

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Am also facing the same issue with windows 7  right now...is that any chenges are going on from microsoft side or do i need to talk with my security team?can anyone please answer from microsoft side?

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I don't know if it is a Windows issue or what it is. One user had this problem and I didn't found any malware or virus at his computer.
SFC didn't found any issues and the disk integrity is fine, so I searched some IT forums and found this and it seem to "solve" the problem.

- Open "Run" and digit "gpedit.msc"
- Go to "Computer Settings > Windows Settings > Security Settings > Local Policies > Security Options
- search "User Account Control: Run all administrators in Admin approval" and set it to ENABLE
- Open "Run" again and do a "gpupdate /force"

If you can't turnoff after the gpupdate then kill and rerun "Explorer.exe".

After the reboot PC seems to not lock the shutdown command anymore but I really don't know why this happened.

10 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Try enabling UAC. (FKTakahashi beat me to it)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

There appear to be recent updates related to the crypt32.dll vulnerability that are impacting Win7 machines. I don't have the KB numbers on-hand but there are three recent ones that appear to be on all of our affected machines.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

In our case, it is definitely being caused by the "Adobe Genuine Monitor Service" that is part Adobe's Creative Cloud. The exe that the service runs was is dated 2/3/20, so this is from a very recent update.

We're telling users as a workaround to first logoff their computers then use the "power button" on the Windows 7 login screen to restart.

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I don't know if it is a Windows issue or what it is. One user had this problem and I didn't found any malware or virus at his computer.
SFC didn't found any issues and the disk integrity is fine, so I searched some IT forums and found this and it seem to "solve" the problem.

- Open "Run" and digit "gpedit.msc"
- Go to "Computer Settings > Windows Settings > Security Settings > Local Policies > Security Options
- search "User Account Control: Run all administrators in Admin approval" and set it to ENABLE
- Open "Run" again and do a "gpupdate /force"

If you can't turnoff after the gpupdate then kill and rerun "Explorer.exe".

After the reboot PC seems to not lock the shutdown command anymore but I really don't know why this happened.

This is only applyable on Win 7 Pro / Enterprise / Ultimate.
Blogs: http://www.borncity.com/blog /(Ger) - and - http://borncity.com/win/ (EN)

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

It seems probably, that the Adobe Service is the root cause preventing Windows 7 from shutdown - found that mentioned also within a reddit.com thread. 

@Rahul_PatelDV can you confirm, that Adobe Creative Cloud is installed on your machine. 

In don't think, the crypt32.dll vulnerability is the issue - due to my knowledge, the patch has been shipped only to Windows 10. 

Compiled some details and workaround into a blog post at - maybe it helps:

Windows 7 prevents shutdown / restart (Feb. 2020)

Blogs: http://www.borncity.com/blog /(Ger) - and - http://borncity.com/win/ (EN)

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.