Question

Q: Windows 7 64bit: Windows Update Service Not Running (but it is running in services.msc)

I just got a new desktop computer (Gateway FX6840-03e) It has Windows 7 Home Premium 64bit (not sure what service pack, I'm new to windows 7 as of this computer so i'm not sure where to find that information). It came with a norton security that i didn't bother to activate, I uninstalled it and followed up with Norton Removal Tool. I then installed AVG Free 2011 edition

When I went to Windows Update I have the red x shield and clicking on the check for updates button gives me the error "Windows cannot check for updates because the service is not running. You may need to restart the computer." Windows update service is running in services.msc though.

The first thing I did that i had read about on the product reviews for the computer since it seemed to be a problem with a few other people that bought the computer was to disable the windows update service the go into C:\windows\SoftwareDistribution and delete everything in there and re-enable windows update service afterwords. According to the reviews this worked for most people. However the problem still persisted for me. Google searching has led me to these forums and i've gone through a few threads but haven't gotten a solution yet.

I've run the windows update troubleshooter with no luck
http://windows.microsoft.com/en-US/windows7/Open-the-Windows-Update-troubleshooter

I ran the System File Checker tool
http://support.microsoft.com/kb/929833
It came back with one problem, but the log file created was blank

I ran the Fix It tool in both default and aggressive modes
http://support.microsoft.com/kb/971058

And in one post somebody mentioned that ATI Catylist Control Center was causing their problem so I uninstalled that with no luck (I have re-installed that)

There have been many restarts between all of that above and now i'm not sure what else to try. 

Answer

A:

Well doing some searches on the errors in the windowsupdate.log eventually led me to find that it the problem had something to do with my hard drive being large (1TB) and "Intel
Rapid Storage Technology (RST)" drivers needed to be updated. Once I got the driver updated my windows update started working fine. Thanks for the help that led me to the answer.

Did this resolve your issue?

Sorry this didn't help.

232 people were helped by this reply



 
Question Info

Views: 316144 Last updated: November 9, 2017 Applies to: