Windows 10 Version 2004 Internet Access

Since updating my Dell Iaptop to Windows 10 Version 2004, Network and Internet settings is showing that my home wifi network has "No Internet Access" when in fact it is working fine. I've rebooted my laptop, reset the router and reinstalled the network wireless adaptor but still same message. 

More an annoyance that a major issue, but does anyone know how to fix this mis-information?  


* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Fixed my problem. Might fix yours: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NlaSvc\Parameters\Internet DWORD EnableActiveProbing was set to 0, change it to 1. Fixed it.


9 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I recently upgraded from 1903 to 2004 and am having the same issue.

I didn't have the 'Internet' key or the 'EnableActiveProbing' DWORD. I put them in anyway but it didn't resolve the issue so I removed them.

My wireless internet works fine but Windows is reporting that my internet isn't available. My wireless internet was correctly being identified just fine in 1903.

When I go to Troubleshoot it's telling me that I need to be connected to the internet to see recommendations. I already tried to reset my adapter settings and was able to reconnect to the same wireless but Windows STILL doesn't recognize that the internet is available. I've already tried other basic diagnostics steps to no avail. I really don't want to roll back just because of this.

I'm using an HP 14 dq1039wn. It's got the 2x2 Realtek RTL8822CE 802.11ac PCIe Adapter. All drivers are up to date according to Microsoft Update. I've got no AV on this system (Windows Defender is disabled).

This really sucks. Do you all remember when Microsoft announced that Windows 10 would be the last version? They promised that they'll have much better QC for updates and upgrades since they won't have to continue to work on multiple Windows versions. What a bunch or horse$#!7

Edit - This is becoming a bigger issue. Since Windows doesn't 'detect' my internet connectivity, even though my internet is working fine, all the other Microsoft apps are drinking the 'no internet' Kool-aid as well. I can't save to OneDrive from within Microsoft apps and Microsoft Outlook isn't working. :(

Edit 2 - I've fixed the issue on my system. It appears that after the 2004 update this key in my registry was completely empty -

Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NlaSvc\Parameters\Internet

Once I replaced the standard values that were there prior to upgrading it started working. Below is the reg key info in standard text, for anyone who's interested. Note that I take no responsibility for the plague, sunburns, stubbing your toe, or this reg key import somehow messing up your system - use at your own risk!

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NlaSvc\Parameters\Internet]
"ActiveDnsProbeContent"="131.107.255.255"
"ActiveDnsProbeContentV6"="fd3e:4f5a:5b81::1"
"ActiveDnsProbeHost"="dns.msftncsi.com"
"ActiveDnsProbeHostV6"="dns.msftncsi.com"
"ActiveWebProbeContent"="Microsoft Connect Test"
"ActiveWebProbeContentV6"="Microsoft Connect Test"
"ActiveWebProbeHost"="www.msftconnecttest.com"
"ActiveWebProbeHostV6"="ipv6.msftconnecttest.com"
"ActiveWebProbePath"="connecttest.txt"
"ActiveWebProbePathV6"="connecttest.txt"
"EnableActiveProbing"=dword:00000000
"PassivePollPeriod"=dword:0000000f
"StaleThreshold"=dword:0000001e
"WebTimeout"=dword:00000023

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NlaSvc\Parameters\Internet\ManualProxies]

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Try

delete registry 

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\NetworkConnectivityStatusIndicator]

@=""

"NoActiveProbe"=dword:00000001

Edit Registry

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NlaSvc\Parameters\Internet]

"EnableActiveProbing"=dword:00000000

Restart your computer

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

i've tried this solution but no luck:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NlaSvc\Parameters\Internet DWORD EnableActiveProbing was set to 0, change it to 1.

So i've tried another solution with luck:

Chane the DNS server address of netwwork adapter to 8.8.8.8 (google DNS) then the issue has fixed.

This solution is the temporary solution. We need to wait the next official patch from Microsoft.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I don't know what did it, but these entries fixed it for me. Thank you!!! I also had the Office and Update issues.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi - This issue appears to be related to the Internet connectivity tests the the windows 10 client runs as it's booting up.   It looks for an a response to http://www.msftconnecttest.com/connecttest.txt  for IPv4 connectivity, and similar response to http://ipv6.msftconnecttest.com/connecttest.txt  for IPv6 connectivity.  You can browse to these URLs to see what the response looks like. Sadly, it looks like since IPv6 is not fully implemented everywhere yet, that if that part of the test fails, it marks the connection as having no Internet access.

Without messing about with registry settings or IPv6 settings on your workstation a simple workaround is to fool the PC that the v6 test worked.   Since the FQDN for www and ipv6 URLs only resolve IPv4 and IPv6 addresses respectively, if you do an NSLOOKUP of www.msftconnecttest.com and note down the IPv4 address that you get returned, then open your HOSTS file (usually found in C:\Windows\System32\drivers\etc\ ) and add the following entry:

<ipv4 address from a lookup of www.msftconnecttest.com>     ipv6.msftconnecttest.com   

Then save that, and check it worked by "PING  ipv6.msftconnecttest.com <Enter> "  you should see it try to ping the IPv4 address.  (Don't worry if no reply to ping - you are just checking the name resolution - so DON'T use nslookup, as that skips checking the HOSTS file)

Now reboot and see if problem is solved.

NB This worked for us since it appears that at least microsoft are not restricting IPv4 traffic hitting the website for www.msftconnecttest.com , but wanting the url http://ipv6.msftconnecttest.com/connecttest.txt    

Give it a try!

NB - I take no responsibility for any side effects (eg PC thinking it really does have IPv6 connectivity when maybe it doesn't).   AND if you are on a corporate LAN - there are other issues - ie this test is not proxy aware, so you may need to allow direct Internet access through your firewall to the IPv4 target address on http only....

DavidBonne

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

HI

i HAVE THE SAME PROBLEM, PLUS AN ADDITIONAL HIGH-RISK ISSUE THAT YOU TOO MIGHT EXPERIENCE?

IF YOU CHECK ALL AVAILABLE WIFI NETWORKS YOU MAY DISCOVER THAT ALL EXTERNAL WIFI NETWORKS, TO WHICH YOU DO ABSOLUTELY NOT WANT TO BE CONNECTED, ARE BY DEFAULT "LOCKED" TO BE "CONNECTED AUTOMATICALLY"!!!

IF YOU REMOVE THE CHECKBOX MARK AND REOPEN THE LIST, YOU WILL FIND THAT THE CHECKMARK IS AUTOMATICALLY REINSERTED! 

WHILE PERFORMING THIS EXCERCISE WITH THE CHECKBOX/-ES FOR YOUR IN-HOUSE PRIVATE NETWORK/-S THE CHECKMARK BOX REMAINS IN THE STATE YOU LEFT IT.

THERE ARE SEVERAL REPORTS ON THIS ISSUE ON THE WEB AND NO APPARENT FIX EXCEPT BLOCKING THESE NETWORKS USING A DOS BOX AS ADMINISTRATOR AND ISSUE  TEXT LINE COMMANDS, OR AS I HAD TO DO MYSELF AS MICROSOFT DOES NOT SEEM TO CARE ABOUT THIS SEVERE SECURITY ISSUE, MAKE A BATCH FILE TO BLOCK ALL THE EXTERNAL WIFI NETWORKS APPEARING IN THE LIST AND VERIFY THEY ARE NOT APPEARING.

IT MAY EVEN BE REQUIRED TO REPEAT THIS ROUTINE AFTER WIN 10 UPDATES AS THEY FREQUENTLY REMOVE BOTH SETTINGS AND INSTALLED SOFTWARE.

I HAVE ADDRESSED THIS ISSUE SEVERAL TIMES TO MS TECH SUPPORT COMMUNITY WITHOUT SEEING ANY FIX TO ADDRESS THIS MAJOR SECURITY HOLE YET.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

That didn't work for me (nor any of the many things suggested by others), but led me to this similar suggestion that did work. Thx

    https://support.umbrella.com/hc/en-us/articles/230900948-Umbrella-Roaming-Client-Microsoft-Windows-Limited-Network-Connectivity-Warning-Yellow-Triangle-

  1. Press the Windows key or go to the start menu.
  2. Type Notepad in the search field.
  3. In the search input box, right-click Notepad and select Run As Administrator.
  4. In Notepad, open the following file: C:\Windows\System32\drivers\etc\hosts
  5. Append the following to the hosts file: 131.107.255.255   dns.msftncsi.com
  6. Click File and Save.
  7. Reboot the system

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks for the tag :)  - We've added your suggestion to our "possible solutions" list, especially for home Users to try.   Hopefully MS will support people still transitioning to full IPv6 capability in future patches. 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

In my case, when connected via OpenVPN, Windows 10 Update 2004 was showing "No Internet Connection", but everything was still working fine. Except the apps like Spotify that rely on this network state stopped working.

EnableActiveProbing=1 or configure for Google DNS was not enough to remedy the situation.

I had to enable the Group Policy "Specify Global DNS", with option "UseGlobalDNS" enabled.

AFAIU, this will allow the DNS probing happen through ANY suitable network interface.

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NlaSvc\Parameters\Internet]

"EnableActiveProbing"=dword:00000001

 

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\NetworkConnectivityStatusIndicator]

"UseGlobalDNS"=dword:00000001


Source: https://github.com/DNSCrypt/dnscrypt-proxy/wiki/Installation-Windows#troubleshooting

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated October 26, 2020 Views 4,199 Applies to: