Windows 10 unable to disable touch screen since Windows reset (HID missing, no option to disable in Pen and Touch)

Hello,

After having looked all over the internet, and being called back by an employer of Microsoft, who couldn't help me either, I turn to you guys, hoping that there is someone out there who knows the solution to this problem.

Since a few years my Dell XPS touch screen has been firing randomly (some points on the screen fire more frequently than others). At first I tried to solve that problem, but nothing helped. So, for the last couple of years I had my touch screen disabled. Sometimes, after a Microsoft update, it was automatically enabled again, so I had to disable it again. Because I did not have the "Human Interface Device" option in my Device Manager, I disabled the touch screen by unchecking "Use your finger as input device" on the "Touch" tab within the "Pen and Touch" settings. This worked perfectly, no longer a firing touch screen, no longer being able to use the touch screen either, but this touch screen was pretty crappy anyway, so I don't miss it.

Because for multiple months my computer was not able to update anymore, and nothing I tried helped, a few weeks ago I had to reset my Windows 10.  All my files were deleted, and Windows was completely removed and reinstalled. This of course re-enabled my touch screen.

The problem is that since the re-installation of Windows 10, the option to not "Use your finger as input device" has disappeared, and has not been replaced by any other option to disable my touch screen (also checked the "settings" button on the same tab). There is still no "Human Interface Device" (HIM) in Device Manager, so still no disabling my touch screen through that approach. I have tried several suggestions I found on the internet to get the HIM to appear, but none worked.

One of these attempts was to set "Human Interface Device Services" to automatic in the "Services" list under "Computer Management" (restarted PC several times since) - still no HID in the Device Manager.

In summary, there appears to be no way to disable my touch screen in order to prevent it from frequently firing without anything touching it. This renders my pc almost unusable, because the random firing is not only very annoying, it can also cause problems when things on the screen are clicked that should not be clicked.

Please help!

Thanks

 

Question Info


Last updated October 25, 2018 Views 90 Applies to:
Answer
Answer

Not sure about the Pen & Touch route, and not at my Win10 computer to capture any screenshots, but will try to help.

Is Device Manager set to show Hidden devices?

View => Show hidden devices

In your screenshot, you have an:

?Other Devices => ?Unknown Device

branch.  Have you tried uninstalling that & then restarting to see if the hardware is redetected properly?

Try switching the View to Devices by Connection. (This is where I wish I could capture a screenshot). Keep expanding branches until you find the Unknown Device which will probably be under a USB Root Hub. But you want to try to delete & redetect the 'parent' device of the unknown device (I hope this makes sense).

Getting the touchscreen to reappear in Device Manager will give you the means to disable it. It will also let you determine the device path, which will allow you to create a one-click shortcut on your Desktop to disable the touchscreen when Windows decides to be "helpful."

I feel your pain. I fought a similar issue for two years.

Keith

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.