Windows 10 - Software is not using dedicated GPU

Hi all,

My laptop running windows 10, with an integrated GPU Intel and dedicated GPU Nvidia. Recently, some softwares, especially video converters don't use the dedicated GPU for accelerating conversions, which is used to work well. I've tried many possible ways (such as: clean uninstall the nvidia drivers and reinstall, force the video converters to run with high performance nvidia processor,...) but none of those works.

Here are some pictures for details.

I really need your helps on this issue. Please help, thank you.

 

Question Info


Last updated November 9, 2019 Views 1,393 Applies to:
Hi Hung

Open the Settings App

Go to System - Display - Graphics Settings

Have you added those video converters to the list there and set those to high performance to force use of your Nvidia GPU?
___________________________________________________________________

Power to the Developer!

MSI GV72 - 17.3", i7-8750H (Hex Core), 32GB DDR4, 4GB GeForce GTX 1050 Ti, 256GB NVMe M2, 2TB HDD

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Dave,

Thank you for prompt reply. I've already set up as yours. But it still doesn't work as expected :(. Any other possible ways?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Hung

I am unfamiliar with those converters, do they support CUDA

See the sheet below for AiseeSoftto see if your card is supported:
https://www.aiseesoft.com/cuda.html

See how to enable CUDA on Video Converter ultimate:
https://www.any-video-converter.com/speedup-con...
___________________________________________________________________

Power to the Developer!

MSI GV72 - 17.3", i7-8750H (Hex Core), 32GB DDR4, 4GB GeForce GTX 1050 Ti, 256GB NVMe M2, 2TB HDD

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The notebook will consume more watts when using dGPU than iGPU.

Intel and AMD each have technology to use iGPU instead of dGPU to conserve battery power.

Many end users use a notebook as a desktop replacement.

Some computer manufactures have settings in the BIOS to turn off the Intel or AMD technology.

For example the HP computer that I am using to type this chat had the Optimus technology turned off in the BIOS.  Opening device manager > display adapters > only Nvidia Quadro is displayed.  The processor (Intel i7 4810MQ) has iGPU but the iGPU is no longer displayed.

If you prefer to only use dGPU open the BIOS and see whether there are available setting changes.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The notebook will consume more watts when using dGPU than iGPU.

Intel and AMD each have technology to use iGPU instead of dGPU to conserve battery power.

Many end users use a notebook as a desktop replacement.

Some computer manufactures have settings in the BIOS to turn off the Intel or AMD technology.

For example the HP computer that I am using to type this chat had the Optimus technology turned off in the BIOS.  Opening device manager > display adapters > only Nvidia Quadro is displayed.  The processor (Intel i7 4810MQ) has iGPU but the iGPU is no longer displayed.

If you prefer to only use dGPU open the BIOS and see whether there are available setting changes.

Hi question_

Unfortunately, there is no option in my laptop BIOS to choose specific GPU (integrated or dedicated) being main one.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Hung

I am unfamiliar with those converters, do they support CUDA

See the sheet below for AiseeSoftto see if your card is supported:
https://www.aiseesoft.com/cuda.html

See how to enable CUDA on Video Converter ultimate:
https://www.any-video-converter.com/speedup-con...

Hi Dave,

Yes, I checked, they do support CUDA to accelerate conversions. I also enabled this option in software but it still doesn't work :(

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This is a trial and error step.

It may or may not work.

Typically Windows will install default Microsoft drivers if the Intel GPU drivers are uninstalled.

The performance is better with computer manufacturer drivers if it were the only device.

If you can disable the Intel GPU then maybe only the Nvidia GPU would be in use.

There was no BIOS setting.

Open device manager > click view > click show hidden devices > expand display adapters > look for the Intel GPU > right click disable device

See if this then forces the use of Nvidia GPU for the software.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi, question,

When I've tried to disable iGPU and Microsoft Basic Display Driver appears to replace.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Running out of ideas.

This link has manually configure Optimus for Dell computers.

See if there is anything useful to modify the computer settings on your computer.

https://www.dell.com/support/article/us/en/04/sln146534/configuring-nvidia-optimus-and-amd-switchable-graphics-for-high-performance-on-your-alienware-system?lang=en

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Running out of ideas.

This link has manually configure Optimus for Dell computers.

See if there is anything useful to modify the computer settings on your computer.

https://www.dell.com/support/article/us/en/04/sln146534/configuring-nvidia-optimus-and-amd-switchable-graphics-for-high-performance-on-your-alienware-system?lang=en

:D thank you for your support.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.