Windows 10 says I have no internet connection, but I have.

I am running on Windows 10 Enterprise, Version 2004, OS Build 19041.264.
I recently changed to the Windows Insider Program and updated Windows. In the taskbar, the Wi-Fi icon shows No Internet Access, but I have a stable internet connection wirelessly (Ex: I can browse the internet, ping IP Addresses, etc.). Another problem is when I try to open Cortana it also says that I have no internet connection (By the way, I can also open Microsoft's website).

As I know Windows checks internet connectivity with this URL: http://msftconnecttest.com/connecttest.txt. But this gives Error 404, File Not Found. Maybe it is because of this?

If you know the problem or an answer, please help. Thanks!
|
Answer
Answer

Hello, use Registry Editor, go to: 
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NlaSvc\Parameters\Internet
and modify: EnableActiveProbing
then change "Value data" from "0" to "1"

and restart your computer

164 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Answer
Answer

The proper one is

"HKLM:\SOFTWARE\Policies\Microsoft\Windows\NetworkConnectivityStatusIndicator\” -Name UseGlobalDNS -PropertyType DWORD -Value 1 -Force

But the more appropriate way to do this is not through registry directly, but through group policy config:

5 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated January 22, 2022 Views 96,459 Applies to: