Windows 10 says I have no internet connection, but I have.

I am running on Windows 10 Enterprise, Version 2004, OS Build 19041.264.
I recently changed to the Windows Insider Program and updated Windows. In the taskbar, the Wi-Fi icon shows No Internet Access, but I have a stable internet connection wirelessly (Ex: I can browse the internet, ping IP Addresses, etc.). Another problem is when I try to open Cortana it also says that I have no internet connection (By the way, I can also open Microsoft's website).

As I know Windows checks internet connectivity with this URL: http://msftconnecttest.com/connecttest.txt. But this gives Error 404, File Not Found. Maybe it is because of this?

If you know the problem or an answer, please help. Thanks!

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hello,

With Windows 10 1909 all worked fine. After the upgrade to Windows 10 2004 it straight started to complain that "No internet Access".  Although internet both for my Wifi and Ethernet connection just work fine.

However applications like Spotify don't check themselves for internet Server reachability but rely on the status that Windows 10 reports. So that i.e. means Spotify goes into OFFLINE mode. 

I tried reseting the adaptors (ethernet and wifi) but without success. 

Brgds,

Bas. 

10 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

As I know Windows checks internet connectivity with this URL: http://msftconnecttest.com/connecttest.txt. But this gives Error 404, File Not Found. Maybe it is because of this?

That's a known issue in the Windows 10 2004 update and is being investigated by Microsoft currently. Please file a feedback using the feedback hub if you are facing the issue.

As for the no internet connection issue, try looking into this thread- https://answers.microsoft.com/en-us/windows/forum/all/windows-shows-no-internet-access-but-my-internet/2e9b593f-c31c-4448-b5d9-6e6b2bd8560c

If my reply is helpful, please mark it so.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Feedback hub also doesn't work - it says I'm not connected to the internet, yet I'm typing this here now...... I'm so angry that I updated to 2004 :-(

EDIT: UPDATE - And suddenly, without any action from my side, the icon now shows "INTERNET ACCESS" again

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I can confirm the sam issue with feedback hub too.

setting in registry enableprobing to 1.  For the moment solved it. 

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello, use Registry Editor, go to: 
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NlaSvc\Parameters\Internet
and modify: EnableActiveProbing
then change "Value data" from "0" to "1"

and restart your computer

115 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I updated my HP Laptop the other day and it started not showing my internet and was having issues, so reverted back to previous version of Windows 10. Is there going to be bug fix for these issues.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

It's not bug. It's just wrong setting.

I showed a way to enable the display of the Internet in Windows settings (Windows Registry)

The Windows Registry is a hierarchical database that stores low-level settings for the Microsoft Windows operating system and for applications that opt to use the registry. 

(from Wiki)

7 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I tried to edit the registry, but could not find HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NlaSvc\Parameters\Internet

so I searched my registry for "EnableActiveProbing" and found it under Computer\HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\NlaSvc\Parameters\Internet and changed  EnableActiveProbing from 0 to 1.

Rebooted my laptop and I can now connect to any of my 4 routers and they all show "Internet Access" perfectly and also connect much faster!

Wonderful!

Thanks so much @ДмитроЖелябін

7 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello, use Registry Editor, go to: 
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NlaSvc\Parameters\Internet
and modify: EnableActiveProbing
then change "Value data" from "0" to "1"

and restart your computer

This is it, this is the answer, worked for me, the only thing that worked actually...

11 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello, use Registry Editor, go to: 
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NlaSvc\Parameters\Internet
and modify: EnableActiveProbing
then change "Value data" from "0" to "1"

and restart your computer

This is it, this is the answer, worked for me, the only thing that worked actually...

I found the same answer on another site and that’s the one that works for me as well

10 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated September 24, 2020 Views 27,648 Applies to: