Windows 10 mouse gets stuck in corner of monitors (dual monitor setup)

I have a rectangular monitor (left) and a square monitor (right).

If I try to move the mouse from the top of the left monitor to the top of the right monitor, it gets stuck. This makes it very frustrating when I'm trying to click-and-drag windows from the lefthand monitor to the right.

It's like Windows 10 decides the right hand monitor is set "lower" (see MS Paint diagram).

I never had this issue with previous versions of Windows.

 

Question Info


Last updated May 19, 2020 Views 8,880 Applies to:

Hi,

We appreciate your efforts in providing us a diagram of the issue. We would like to ask for more information so we could provide a proper resolution:

  • When was the last time you were able to successfully click-and-drag Windows from the left hand monitor to the right?
  • Since when have you been experiencing this issue? Was Windows upgraded recently?
  • What's the exact build of the Windows 10 that you're currently using? To get this information, go to Windows Settings > System > About.

            You can also do this:

                1.Hit Start.
                2.Type winver.
                3.Press Enter.

Installing any important and optimal updates can often correct issues by replacing outdated files and fixing vulnerabilities. The best way to keep your PC current is to turn on automatic updates. With automatic updates, you don’t have to search for updates online or possibly miss critical fixes or device drivers for your Windows PC. Windows Update automatically installs important updates as they become available.

To turn on automatic updates in Windows 10:

 
  1. Select the Start button, then select Settings  > Update & security  > Windows Update . If you want to check for updates manually, select Check for updates.
  2. Select Advanced options, and then under Choose how updates are installed, select Automatic (recommended).

We look forward to your response.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This is a feature of Windows 10, unfortunately. Thus, it has been aggravating people since 2015. I'm disappointed (though not surprised) that you only got a crappy canned message. As far as I can tell, it was implemented by Microsoft on purpose, and there's no way to disable it.

45 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

If you go to the display settings and drag your square monitor up so the upper edges match, this will stop happening in the upper right but will happen instead in the lower right. However, for me, I rarely drag my mouse across down there so it's a much better setup!

37 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.