[Windows 10] Mobile Hotspot is not working.

So I have a Lenovo Y700 laptop with Windows 10 Version 1803 (OS Build 17134.165) running on it. I cannot connect my mobile phone (or any other device) to the Mobile Hotspot's network. I can turn on/off Mobile Hotspot, edit network name, password, and band but my mobile phone does not connect to the network after entering the password. It says "Obtaining IP Address..." indefinitely. 

Are there any drivers that I missing? or what? Thanks a lot! 

|
Hello, Kshitiz26.

First look this important article: https://support.microsoft.com/en-gb/help/10741/...

Make sure that the encryption settings are the same on the host as well as the device connecting to it. You can find out the setting on the Windows host device by running the following command from CMD (admin):

netsh wlan show hostednetwork setting=security

The Authentication setting would be relevant here. Most connections uses WPA2 encryption, this would have to the same on both devices.

Try temporarily Uninstall third party AV (Make sure resources to reinstall is available)

Try Clean boot: https://support.microsoft.com/en-gb/help/929135...

Remove and recreate the network profile on the device trying to connect to the hotspot (Steps for Windows 10 below, if the issue with a third party device, please search for steps on the manufacturer website):
1. Click on the Windows button + I to open Settings
2. Click on Wifi & Internet
3. Click on Manage Wifi Settings
4. Click on the Hotspot you used to connect to, select the option to forget the network.
5. Search for available Wifi connections
6. Select the Hotspot again and follow the on screen instructions.

Let us know how it is going
Best wishes,
Mark

5 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Open a command prompt (right click on the Start and click on Command Prompt)
Type the following command NETSH WLAN show drivers and press Enter
In the results look for a line Hosted network supported, and see if it says Yes or No.

If it says No then this is at fault, since your WiFi adapter does not support this feature, and there is not much to do about it (except buying another WiFi adapter that does support it.)

Open Mobile hotspot settings (Settings > Network & Internet > Mobile hotspot)
Turn on mobile hotspot
Under "Related Settings", click Change adapter options
Take note of which adapter is connected to the internet and which adapter is your mobile hotspot (typically named "Local Area Connection* [#]")
Right click the adapter that is connected to the internet and click Properties
Go to the Sharing tab
Uncheck "Allow other network users to connect through this computer's Internet connection". If it is already unchecked, skip this step.
Click OK
Again, open Properties > Sharing for the same adapter.
Check "Allow other network users to connect through this computer's Internet connection"
(If you get a popup that says "Internet Connection Sharing is currently enabled...", click OK.)
Under "Home networking connection:", select the mobile hotspot adapter
Click OK

Press Windows key + X
Click Device Manager
Expand Network adapters
Right click then uninstall all virtual adapters

Open Start then type: regedit
Right click Regedit then click Run as administrator
Navigate to the following registry key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WlanSvc\Parameters\HostedNetworkSettings\

Delete the following key:
HostedNetworkSettings

Restart then try again.

Run the Network adapter troubleshooter

Open Start > Settings > Update & security > Troubleshoot
Scroll down, select Network adapters
Click Run the troubleshooter

When complete, restart to see if it works.

If not, you can try updating both your Network adapter drivers or uninstall them.

Press Windows key + X
Click Device Manager
Expand network adapters
Right click your adapter, click uninstall

Exit Device Manager then restart

Windows 10 will re-detect them and reinstall them.

or

Open Start, type: CMD
Right click CMD
Click Run as administrator

Type in at the prompt OR Copy and Paste these one at a time : (Hit enter after each)

netsh wlan set hostednetwork mode=allow ssid=name key=YOURPASSWORD

netsh wlan start hostednetwork

Exit Command Prompt

Open Start > Settings > Network & Internet > Wi-Fi > 'Change adapter options'

Select the new "Local Area Connection #..."

Right click this and select "Properties",

Choose the "Sharing Tab then check 'Allow other network Users to connect through this computer's Internet connection'

Click Apply then OK
Best regards,
Andre Da Costa
Independent Advisor for Directly

13 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi Kshitiz26,
if you have Bluetooth on your PC, try disabling it and then try again.
If it does not resolve, enable mobile hotspot, then open Command Prompt and type ipconfig / all and press enter. Copy all and post the result.

4 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi Kshitiz26,
if you have Bluetooth on your PC, try disabling it and then try again.
If it does not resolve, enable mobile hotspot, then open Command Prompt and type ipconfig / all and press enter. Copy all and post the result.

C:\Users\Kshitiz>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : KY700
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Ethernet 2:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : TunnelBear Adapter V9
   Physical Address. . . . . . . . . : 00-FF-5E-45-FA-7B
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Ethernet adapter Ethernet:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
   Physical Address. . . . . . . . . : 50-7B-9D-84-06-19
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Local Area Connection* 11:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft Wi-Fi Direct Virtual Adapter #3
   Physical Address. . . . . . . . . : E0-94-67-B3-51-15
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Wi-Fi:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Intel(R) Dual Band Wireless-AC 3165
   Physical Address. . . . . . . . . : E0-94-67-B3-51-14
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   IPv6 Address. . . . . . . . . . . : 2405:204:c68c:ef82:85d5:ff4c:1c6c:2069(Preferred)
   Temporary IPv6 Address. . . . . . : 2405:204:c68c:ef82:6d1e:641e:95cf:237a(Preferred)
   Link-local IPv6 Address . . . . . : fe80::85d5:ff4c:1c6c:2069%14(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.43.203(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : Saturday, July 28, 2018 3:41:33 PM
   Lease Expires . . . . . . . . . . : Saturday, July 28, 2018 5:02:32 PM
   Default Gateway . . . . . . . . . : fe80::8fc:6ed0:42b5:2686%14
                                       192.168.43.1
   DHCP Server . . . . . . . . . . . : 192.168.43.1
   DHCPv6 IAID . . . . . . . . . . . : 299930727
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1F-FE-7D-27-50-7B-9D-84-06-19
   DNS Servers . . . . . . . . . . . : 2405:200:800::1
                                       192.168.43.1
   NetBIOS over Tcpip. . . . . . . . : Enabled

Wireless LAN adapter Local Area Connection* 13:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft Wi-Fi Direct Virtual Adapter #4
   Physical Address. . . . . . . . . : E2-94-67-B3-51-14
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::886c:f8c6:ab57:cb8d%11(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.137.1(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . :
   DHCPv6 IAID . . . . . . . . . . . : 182621287
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1F-FE-7D-27-50-7B-9D-84-06-19
   DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                       fec0:0:0:ffff::2%1
                                       fec0:0:0:ffff::3%1
   NetBIOS over Tcpip. . . . . . . . : Enabled

3 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Open a command prompt (right click on the Start and click on Command Prompt)
Type the following command NETSH WLAN show drivers and press Enter
In the results look for a line Hosted network supported, and see if it says Yes or No.

If it says No then this is at fault, since your WiFi adapter does not support this feature, and there is not much to do about it (except buying another WiFi adapter that does support it.)

Open Mobile hotspot settings (Settings > Network & Internet > Mobile hotspot)
Turn on mobile hotspot
Under "Related Settings", click Change adapter options
Take note of which adapter is connected to the internet and which adapter is your mobile hotspot (typically named "Local Area Connection* [#]")
Right click the adapter that is connected to the internet and click Properties
Go to the Sharing tab
Uncheck "Allow other network users to connect through this computer's Internet connection". If it is already unchecked, skip this step.
Click OK
Again, open Properties > Sharing for the same adapter.
Check "Allow other network users to connect through this computer's Internet connection"
(If you get a popup that says "Internet Connection Sharing is currently enabled...", click OK.)
Under "Home networking connection:", select the mobile hotspot adapter
Click OK

Press Windows key + X
Click Device Manager
Expand Network adapters
Right click then uninstall all virtual adapters

Open Start then type: regedit
Right click Regedit then click Run as administrator
Navigate to the following registry key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WlanSvc\Parameters\HostedNetworkSettings\

Delete the following key:
HostedNetworkSettings

Restart then try again.

Run the Network adapter troubleshooter

Open Start > Settings > Update & security > Troubleshoot
Scroll down, select Network adapters
Click Run the troubleshooter

When complete, restart to see if it works.

If not, you can try updating both your Network adapter drivers or uninstall them.

Press Windows key + X
Click Device Manager
Expand network adapters
Right click your adapter, click uninstall

Exit Device Manager then restart

Windows 10 will re-detect them and reinstall them.

or

Open Start, type: CMD
Right click CMD
Click Run as administrator

Type in at the prompt OR Copy and Paste these one at a time : (Hit enter after each)

netsh wlan set hostednetwork mode=allow ssid=name key=YOURPASSWORD

netsh wlan start hostednetwork

Exit Command Prompt

Open Start > Settings > Network & Internet > Wi-Fi > 'Change adapter options'

Select the new "Local Area Connection #..."

Right click this and select "Properties",

Choose the "Sharing Tab then check 'Allow other network Users to connect through this computer's Internet connection'

Click Apply then OK

It said Hosted Network is NO, that means not supported. So do I still need to do the following steps? Or should I get a new WiFi adapter?

2 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi Kshitiz26,
-1) Disable mobile hotspot.
-2) Right-click on the network adapter connected to the internet> Properties> Sharing tab, deselect both checkboxes and confirm by pressing OK.
-3) Enable mobile hotspot and try to connect again.
If it does not work, post the screenshot of your device connected to the mobile hotspot with the error message.
-Make sure that the Sharing tab of the main adapter remains set as in the example:

14 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated June 18, 2021 Views 28,798 Applies to: