Windows 10 Desktop computer wont sleep, it only shuts off the screen like a tablet. Help.

Like the title says, when I hit the sleep button on my keyboard, the screen just shuts off, but the computer remains on.

This only happens once in a while, most of the time it will sleep like normal. I can turn the screen back on when I move my mouse, which doesn't work if its actually asleep, as I have it set not to. So it must not actually be asleep, which is clear, but why??

I have to restart the computer to correct this.

Any clue whats going on here??

Thanks.

|

Hi,

Thank you for posting your query in Microsoft Community.

I understand your concern and will assist you to resolve this issue.   

I suggest you to follow the methods below and check if it helps.

Method 1: Run the Power troubleshooter.

Windows 10 has a built-in troubleshooter to check and fix issues with power. I would suggest you to run this troubleshooter to check if the issue is with your Power.

Refer these steps:

  1. Press Windows key +X, select Control panel.
  2. Change the view by option on the top right to Large icons.
  3. Click on troubleshooting and click on the view all option on the left panel.
  4. Run the Power troubleshooter.

Method 2: I suggest you to update drivers and check if that helps. If that issue persist please uninstall and reinstall latest drivers available in manufacturer website. Both Display driver and Audio drivers.

  1. Press “Windows + X” and select Device manger.
  2. Select Display Adapter and expand the driver icon.
  3. Right click on the driver icon and click on Update.
  4. Follow the onscreen instructions to update the driver.

Hope this helps. If the issue remains unresolved, please get back to us and we would be happy to help.

9 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Its been a while, but I'm writing back to say that this problem still persists. I tried what you suggested and to no avail.

The screen shuts off when I press the sleep key on my keyboard, but the computer remains on, moving the mouse or hitting a key turns the screen back on. Its does not even present me with the login screen, it stays at the desktop.

This seems to be a once a week occurrence.

Any other suggestions?

Thanks.

2 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi,

I suggest you to reset the Power settings and then try again to check for the results.

1. Press Windows key + X from the keyboard.

2. Choose Command prompt from the context menu.

3. In the command prompt, type powercfg –restoredefaultschemes and press Enter.

4. Exit command prompt.

If the issue persists, I suggest you to create a new power plan and check if it helps to resolve the issue.

http://windows.microsoft.com/en-us/windows/power-plans-faq#1TC=windows-8
Note: Applies to Windows 10 as well.

Let us know if you need further assistance. We will be happy to help.

Thank you.

3 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Ok, I will try this and get back to you in the next week or so, (Like I said, Its a once a week thing, so it takes a while to find out if this worked.)

Thanks.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi,

Thank you for the update and please do let us know if you need further assistance. We will be glad to assist you.

Thank you.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Nope, its still doing it, but I discovered a bit of information that's very important and confirms my suspicions.

In the Event viewer, when this issue occurs, my attempts to sleep my computer show up as "The system is entering Away Mode." (Event ID: 59) instead of "The system is entering sleep." (Event ID: 42).

Whats causing it to chose "Away mode" is beyond me.

Hopefully this helps diagnose the problem.

Also, I discovered that I can force it to sleep via the command "rundll32.exe powrprof.dll,SetSuspendState 0,1,0" via the command prompt.

Its seems that the function of the sleep button, both on the keyboard and in the start menu, is changed to "away" mode instead of "sleep" mode.

11 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I think I need to bump this!

I'm still having the problem described in the previous posts, and I'd love to get a solution as my previous "solution"

being the command "rundll32.exe powrprof.dll,SetSuspendState 0,1,0" does not actually work.

Please, what else can I do??

5 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated June 23, 2021 Views 11,063 Applies to: