Windows 10 "Always open with" doesn't work!

Hi,


I am trying to choose a program to always open my .lua files with. But it wont work! When I choose the program of my liking and hit "Always open with" and press OK, it opens the file but does not change the always open with choice. I tried selecting another program and then select the one I want and hit OK, but still same issue.

I have even tried to left click "Properties" -> and change "Open with" but when I pick a program it doesn't change. This problem is driving me crazy and happens with all extensions I try to do this with.

The only thing that works is the default things such as which browser to use etc.

I would value any help I could get, thanks!

(Plus the windows was freshly reinstalled 2 weeks ago)

 

Question Info


Last updated August 19, 2019 Views 1,970 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hello,

 

Thank you for writing to Microsoft Community Forums.

Did you try setting the default file type application from system Settings page?

I suggest you to try the below steps to set the default file type application.

  1. Press Windows logo key on the keyboard, type Default Programs and select the top most search result.
  2. Scroll down the page and click on Choose default apps by file type from the window.
  3. Locate the file format, click on the program which is set to open the file type and select the application you want to set from Choose an App window.
  4. Close the window and check if you are able to open the file type in the application set as default.

 

Hope it helps.

 

Sandeep Kumar M

 

Microsoft Community - Moderator

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello,

Thank you for writing to Microsoft Community Forums.

Did you try setting the default file type application from system Settings page?

I suggest you to try the below steps to set the default file type application.

  1. Press Windows logo key on the keyboard, type Default Programs and select the top most search result.
  2. Scroll down the page and click on Choose default apps by file type from the window.
  3. Locate the file format, click on the program which is set to open the file type and select the application you want to set from Choose an App window.
  4. Close the window and check if you are able to open the file type in the application set as default.

Hope it helps.

Sandeep Kumar M

Microsoft Community - Moderator

Hi,

Thanks for the reply.

.lua is not an option in there apparently, so this would not solve my issue :(

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

So no solution? :(

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have the same issue and it is driving me MAD!!!

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This is happening to me as well - I did a clean install of Windows 10, installed all updates.  I can't change ANY file associations.  

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I did n inplace upgrade with latest ISO and that resolved my issue

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Come on Windows, I am an adult. Let me choose ANY program I want to open ANY file type I want and let me keep it that way.

Please fix this, Microsoft. Make Windows 10 at least as good as 7.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Sandeep,

I am having a similar problem, but for the common .xml filetype. Here is a screen capture of trying to follow the steps you provided: https://i.imgur.com/wrFG6xo.gifv

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Any updates??

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Unfortunately not :(

Microsoft messed up with their last update.. And now they are leaving us hanging. 

7 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.