Windows 10 5.1 surround sound not working

I have upgraded to Windows 10 and my 5.1 surround sound is not working i use the same drivers that i used on windows 7 and they worked. When i go to test the surround sound it works but when i go in games there is no sound at all.
Hi,
 
Thank you for posting in Microsoft community. I understand the inconvenience caused to you.
 
Please provide us with the following information to assist you further:
 
1. What is the make and model of the computer?
2. Does the issue occur only with games?
 
Since the surround sound works fine, I would suggest you to check the sound settings in the game and make changes accordingly.
 
Please contact the game support and check on how to change the game audio settings.
 
Follow the below steps to check the sound settings: 
 
1. Right click the speaker icon in the corner.
2. Select "playback devices"
3. Select correct speakers and click on "configure" (lower left)
4. Walk through configuration menu. Make 5.1
5. Select correct speakers and click on "property's" (lower right).
6. Select Tab "Enhancements".
7. Check "Speaker Fill".
 
Hope the information helps. Please let us know if the query is unresolved, we will be happy to assist you further.

11 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I've had the same problem since the launch of Win 10, upgrading from 8.1. Onboard surround sound was fine using Realtek High Definition Audio. Now in Windows 10 I can choose 5.1 surround , which I have. The test works fine as does clicking each speaker icon. They all work fine. However anything requiring audio playback is in stereo only.

5 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I think the OP is saying surround sound doesn't work with anything requiring audio playback, such as games. I have the exact same problem be it gaming, watching video, tv or music. I only get stereo playback even though I have set it up as 5.1 surround with rear speakers. Test works fine. Playback does not. This was not an issue in Windows 8.1 only since upgrading to Windows 10.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Same problem here. I do know that the running the 5.1 test will always work because it's playing back a sound file that is already 5.1 encoded. Running any program that will pass its sound to your hardware for 5.1 encoding gets processed as stereo.

I'm using a SoundBlaster X-Fi 5.1 Pro and everything worked fine in Windows 7. After upgrading to 10 I no longer get 5.1 sound from anything; all stereo. Creative updated their drivers but still no 5.1 so I'm guessing at this point Windows 10 is to blame.

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have same problem with a sound blaster nothing in 5.1, but if I use 7.1 I get playback and everything works fine.

So I am guessing its a windows problem with its 5.1 setup.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I was given a 5.1 speaker system today and was excited about coupling it up to my X-Fi extreme music card and was disappointed when I could not for love or money get it work in 5.1. I had one before when I an Audigy under windows XP and I could alter the cut off point of the bass frequency among other things.

I am running windows 10 upgraded from windows 7 I have no idea if 5.1 worked under 7 as I only used stereo at that time.

just as mentioned running the windows test works fine. Other wise nothing just normal stereo.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,
 
Thank you for posting in Microsoft community. I understand the inconvenience caused to you.
 
Please provide us with the following information to assist you further:
 
1. What is the make and model of the computer?
2. Does the issue occur only with games?
 
Since the surround sound works fine, I would suggest you to check the sound settings in the game and make changes accordingly.
 
Please contact the game support and check on how to change the game audio settings.
 
Follow the below steps to check the sound settings: 
 
1. Right click the speaker icon in the corner.
2. Select "playback devices"
3. Select correct speakers and click on "configure" (lower left)
4. Walk through configuration menu. Make 5.1
5. Select correct speakers and click on "property's" (lower right).
6. Select Tab "Enhancements".
7. Check "Speaker Fill".
 

Hope the information helps. Please let us know if the query is unresolved, we will be happy to assist you further.

I have an ASUS MB (M5A78L-USB3) with a VIA chipset for audio, it WORKED great in Win 7.  Windows 10 it tests fine, but only the front two speakers and bass work.  5.1 does not output sound from the rear jacks, i.e., rear and center TEST OK but DO NOT playback via a web browser.  I have TWO computers with the exact same thing.  On Win 7 I could use the VIA application, that however, will not load or install with Win 10.  Any advice (other than the obvious) would be great.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

5.1 is partial broken for games in Windows 10, think it worked from build 10586.1 to 10586.3 and has not been fixed since.


Setting analog connected speakers up via the sound control panels works fine, same with Creative ZxR's own control panel, even running the tests in both puts sound out correctly on all channels.
But when playing games that support 5.1 it just doesn't work, no sound what so ever goes to the rear speakers, something that does work in Windows 7, 8 and 8.1.

**** me off, since I sold my DTS/DD Surround Sound System and got a 5.1 set with analog inputs meant for PC instead and it still doesn't work!

So dear Microsoft, please fix your *@-! code

Data technician with infrastructure as specialty
dk.linkedin.com/in/joergbaermann

7 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Ok, well on build 15058 (Slow Ring as Fast Ring has caused far too many issues before) Dolby Digital Live still doesn't work. Joerg, you're saying standard 5.1 analogue audio doesn't work either?.  So only standard prerecorded Dolby and DTS work for surround in Windows now.

Surely this is all related to the binaural/spatial audio stuff that's coming, which by the way doesn't work either atm.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated October 28, 2020 Views 12,519 Applies to: