Windows 10 1903 upgrade failure due to Intel Rapid Storage RST driver

Windows 1903 upgrade fails with message that there is a problem with the Intel RST driver. I followed Microsoft's support article

and upgraded the Intel RST driver to the recommended version 15.9.6.1044, but this did not resolve the problem. Even updating

Intel RST driver to the latest version 17.5.1.1021 does not enable The Windows 10 1903 upgrade to run successfully.

 I tried both update mechanisms via Windows Update as well via the Media Creation tool, both with no success no matter which Intel RST driver is installed.

What can I do to successfully update to version 1903 ? Any help is highly appreciated.

Helmut Zimmermann

Cologne/Germany

 

Question Info


Last updated November 13, 2019 Views 10,998 Applies to:
Answer
Answer
I uninstalled the intel RST. Then went to the Windows\System32\Drivers folder found iastora.sys and renamed it iastora.sys.org. Rebooted the system to ensure it would boot up. Reran the 1903 update and tada! The update completed without issue. This was on my HP Pavilion Laptop. The reason I tried this is that I had recently rebuilt this laptop. After the rebuild I installed the HP Support Assistant utility to make sure I got all the latest drivers. During that time the Intel RST installed. So I knew the system would work just fine without it. 

33 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.