Windows 10 1903 (May update) black screen with Remote Desktop

I upgraded my secondary machine from 1809 to 1903. When I access it now using Remote Desktop all I get is a black screen in the RDP windows. I then upgraded my primary machine to 1903 hoping that would help, but no. Fortunately I also have GoToAssist installed so I was able to log into the secondary machine that way and checked for updates, still no help. Finally I reverted it back to 1809 and Remote Desktop once again works. I could keep using GoToAssist but RDP over my local LAN is much faster.

As long as this version as been (more or less) gold before going public, I can't possibly be the first one with this issue. It's no big deal to me that my secondary is running 1809, it's primarily a file server, but upgrading would be nice.

Granted, that secondary system is an older Core2 Quad, but at 3.3GHz and 8GB of memory and a SSD, it's plenty fast enough. I suppose I could try a different video card, but it shouldn't be necessary for a feature update.
Anyone have some insight into why RDP isn't working. I've already been through all the "guesses".   :-)

 

Question Info


Last updated September 16, 2019 Views 15,776 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi Laurie. I'm Greg, an installation specialist and 9 year Windows MVP here to help you.

1) Update the Display driver from the PC or Display adapter maker's Support Downloads web page for your exact model number, HP Serial Number or Dell Service Tag - from the sticker on the PC.

While there check also for newer chipset, BIOS/UEFI firmware (very important), network, sound, USB3 and other drivers, comparing to the ones presently installed in Device Manager reached by right clicking the Start Menu.

if this doesn't give you the latest or ideal driver for what you need, compare it to the driver offered by the Intel driver update Utility here: http://www.intel.com/content/www/us/en/support/...
or the Nvidia Update utility here: http://www.nvidia.com/Download/Scan.aspx?lang=e...
or the AMD autodect utility here: http://support.amd.com/us/gpudownload/windows/P...

For Display issues one fix that is working is to Roll back or Uninstall the Driver on the Display Device > Driver tab, restart PC to reinstall driver.

You can also try older drivers in Device Manager > Display device > Driver tab > Update Driver > Browse > Let Me Pick.

Then you will know you've tried everything in addition to Windows Update drivers.

2) adjust the Screen Resolution at Settings > System > Display until it looks best.

3) Go over this checklist to make sure the install is set up correctly, optimized for best performance, and any needed repairs get done: http://answers.microsoft.com/en-us/windows/wiki...

Start with Step 4 to turn off Startup freeloaders which can conflict and cause issues, then Step 7 to check for infection the most thorough way, then step 10 to check for damaged System Files, and also Step 16 to test a new Local Admin account. Then continue with the other steps to go over your install most thoroughly.

--------------------------------------------

But remember that in Windows 10 everything depends upon the quality of the install, and Factory or Upgrade installs are inferior installs which most enthusiasts won't even run because they'd expect endless issues. Consider now or later doing the Clean Install in this link which compiles the best possible install that will stay that way as long as you stick with the tools and methods given: http://answers.microsoft.com/en-us/windows/wiki...

There is also an automated Fresh Start that reinstalls WIndows while shedding corrupting factory bloatware, saves your files, but doesn't clear the drive to get it cleanest: https://www.howtogeek.com/265054/how-to-easily-...

I hope this helps. Feel free to ask back any questions and let us know how it goes. If you'll wait to rate whether my post helped you, I will keep working with you until it's resolved.

________________________________________________________

Standard Disclaimer: There are links to non-Microsoft websites. The pages appear to be providing accurate, safe information. Watch out for ads on the sites that may advertise products frequently classified as a PUP (Potentially Unwanted Products). Thoroughly research any product advertised on the sites before you decide to download and install it.
_________________

Windows MVP 2010-20

Over 100,000 helped in forums in 10 years
I do not quit for those who are polite and cooperative.
I will walk you through any steps and will not let you fail.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

With your older hardware, you are likely using the Intel Q45/Q43 graphics chipset.  That is the problem. 

If your device is a desktop, get yourself an add-on graphics card.  But...  Be careful regarding compatibility.

Or, wait for Microsoft to fix the problem.

Also, while you are in the black screen, you can CTRL-ALT-END, select Task Mangler, and terminate the Remote Desktop session.

Computers verified since 1972

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Did you ever get this resolved? Not only Can I not RDP into my machine over vpn, I cannot TeamViewer as well.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Same problem here. Old machine with Intel G41 graphics. Remote access with RDP shows black screen, either from LAN or VPN, but mouse and keyboard are ok (I can reboot using the appropriate key sequence).

Remote access with TeamViewer 14.2.2558 seems Ok (I get a black desktop instead of the blue one, but the screen is readable).

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I ended up going to Device manager and checking for an update for Display Adapters. it found and update, I can now RDP internally. I will have to check when I get home if I can via VPN.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

With your older hardware, you are likely using the Intel Q45/Q43 graphics chipset.  That is the problem. 

If your device is a desktop, get yourself an add-on graphics card.  But...  Be careful regarding compatibility.

Or, wait for Microsoft to fix the problem.

Also, while you are in the black screen, you can CTRL-ALT-END, select Task Mangler, and terminate the Remote Desktop session.

I have this problem, too, however I'm not running the Intel Q45/Q43 chipset. I'm running an AMD Radeon R7 350X, on a Dell Optiplex 7040.  All my drivers are updated, and I'm unable to hit ctrl-alt-end to open task manager while at the black screen.

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

In my case all Intel G41 drivers currently available, from Intel (2009), and from Microsoft (2013), showed black screen with RDP, even though they are Ok with the monitor connected to the PC.

So I've decided to use the "Microsoft Basic Graphics" driver, shown in the compatibility list when I tried to update the driver manually, and now RDP works.

22 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

There’s a known issue with some of the old display drivers. 

Display drivers report some of their capabilities upon load. In previous Windows versions this reported data wasn’t used or verified. Because of that, some of the old versions of the legacy display driver may report invalid data and it would be ignored. Starting with Windows 10 1903 RDP uses this data to initialize the session. 

The best option is to install an updated display driver from the hardware manufacturer. If the new version is not available, you can workaround this by disabling the problematic driver in the device manager.

Our team has identified the issue and we are currently verifying the fix that will dynamically switch to the software renderer if the problematic driver is detected.

I will this thread when the fix will be included to the Windows Insider release.

5 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have an AMD chipset. Did you get this resolved? 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

My problem PC was using the Q45/Q43 graphic chipset and I did find that it had the most recent driver.  That did not solve the problem.  HOWEVER, I did solve the problem after reading the previous post by uninstalling my display adapter in Device Manager and then I rebooted the computer.  After reboot, the device did show to be disabled or uninstalled, showing a down arrow on the device in Device Manager, so I am left to assume that it is running on some basic Windows video driver, BUT NOW RDP WORKS!!!

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.