Win 7 to Win 10 upgrade error (0x800707E7 - 0x3000D)

Hello,

I have been trying to upgrade my Windows 7 Home Premium SP1 to Windows 10 multiple times with always the error at the end of it...

I've tried a lot of things that I found on google, here on this forum, and multiple other forums, but none of those worked.

So the install/upgrade of Windows goes on, it reboots 2 times the computer with always lots of loading and installing percentages, the usual stuff. And then after maybe 30-45 minutes the computer reboots back to Windows 7 undoing modifications and a window pops saying :

We couldn't install Windows 10

0x800707E7 - 0x3000D

The installation failed in the FIRST_BOOT phase with an error during MIGRATE_DATE operation.

I can copy/paste the end of the 729 lines long file from C:\$Windows.~BT\Sources\Panther\setuperr.log if it helps. Don't know how useful it is since I think that lots of errors in it are not necessarily triggering the install bug.

2020-06-09 23:47:37, Error                 MIG    Ignoring replacement manifest with no settingsVersionRange or versionRange attribute in migration element: Microsoft-Windows-Container-Manager

2020-06-09 23:47:42, Error                 SP     User profile suffix mismatch, upgrade cannot continue.[gle=0x00000012]

2020-06-09 23:47:42, Error                 SP     pSPExecuteApply: Migration phase caught exception: Win32Exception: User profile suffix mismatch, upgrade cannot continue: The specified profile is intended for a device of a different type than the specified device. [0x000007E7] enum MIGSTATUS __cdecl pSPExecuteApply(enum SetupPlatform::SP_MIG_SCOPE,class UnBCL::String *,int,int,int,class UnBCL::ArrayList<class UnBCL::String *> *,class UnBCL::String *,class UnBCL::String *,class UnBCL::ArrayList<class UnBCL::DictionaryEntry<class UnBCL::String *,class UnBCL::String *> *> *,class UnBCL::String *,int,int,class UnBCL::String *,class UnBCL::String *,class UnBCL::String *,class UnBCL::String *,class UnBCL::String *,class UnBCL::String *,class UnBCL::ArrayList<class CWIMBootData *> *,class UnBCL::String *,int *,class CSPTelemetryData *,struct ISPMigProgress *,long *)

2020-06-09 23:47:42, Error                 SP     Apply (first boot apply, online phase): Migration phase failed. Result: 4, specific error: 0x800707E7[gle=0x00000002]

2020-06-09 23:47:42, Error                 SP     Operation failed: First boot apply. Error: 0x800707E7[gle=0x000000b7]

2020-06-09 23:47:42, Error                 SP     Operation execution failed: 13. hr = 0x800707E7

2020-06-09 23:47:42, Error                 SP     ExecuteOperations: Failed execution phase Post First Boot. Error: 0x800707E7

2020-06-09 23:47:42, Error                 SP     Operation execution failed.

2020-06-09 23:47:42, Error                 SP     CSetupPlatformPrivate::Execute: Failed to deserialize/execute post-FirstBoot operations. Error: 0x800707E7

I don't want "solutions" saying to make a clean new installation, I want to keep my files + applications + conf stuff...

Thank you in advance for any help.

|
Answer
Answer

So the problem was indeed a wrong user, in my case it was the user "UpdatusUser". It was tricky because it is a hidden user.

After some research I found that this user is created by NVIDIA since version 270 on desktop computers (previous version on some laptop computer already used the "UpdatusUser").

This account executes the NVIDIA update service to update things (like drivers) through the NVIDIA's server. So it seems to be a common thing for NVIDIA updates.

But this account is the problem to Upgrade Windows 10.

  1. So I uninstalled all NVIDIA drivers installed on my computer, mostly installed with NVIDIA GeForce Experience app. It requires a reboot after each unintall.
  2. After that I move removed 2 weird users in User Profiles dialog in System Properties like so :
    1. With main user (with admin privileges)
    2. Open Properties for Computer
    3. Advanced system settings (on the left side)
    4. Settings for User Profiles (in the middle)
    5. And in the list of "Profiles stored on this computer" I found a default profile + my profile with my name. But there were 2 others profiles which I did not know so I deleted them.

  3. Then I remove the "UpdatusUser" folder found in "C:\Users\UpdatusUser"
  4. After that I went to Start → Run → Regedit. (You can also press Windows key + R can to open the "Run" window and then type "Regedit" in it, then press enter.) 
  5. Navigate to the following registry key : HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList
  6. And remove all entry which contains a value with "UpdatusUser" in it.
  7. After all that I did a reboot to be safe.
  8. And I finally launched the media creation tool "MediaCreationTool2004.exe" to upgrade to Windows 10

After the installation of Windows 10 I reinstalled the NVIDIA GeForce Experience app with all drivers and everything is back to normal :)

Thanks again for your tips on the possible Profile problem !

All the best !

I am just making this post so you can mark it as an answer.  I don't care about the credit but it would be good to show it solved..

_____________________________________
ASUS Z490 Intel i9 10900K
Fully Win 11 Qualified

43 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated August 3, 2021 Views 21,173 Applies to: