Win 10 can't browse folder share from Win 2003


Win 10 can't browse files from folder sharing in Windows server 2003, how to solve it?

if i browse using windows 7 it's OK

Open Start > Settings > Network & Internet > Status
Scroll to the bottom
Click Network and Sharing Center

Click Change advanced sharing settings
Expand All Networks
Under Password protected sharing

Switch between 'Turn on password protected sharing and Turn off password protected sharing'

Then choose 'Turn off password protected sharing'

Then click 'Save changes'


Press Windows key + R
Type: optionalfeatures.exe
Hit Enter

Scroll down to SMB 1.0/CIFS File Sharing Support
Tick the SMB 1.0/CIFS Client
Untick SMB 1.0/CIFS Automatic Removal and
Untick SMB 1.0/CIFS Server

Click OK
Restart if prompted.

Additional troubleshooting steps you can attempt:
- shut all computer and network gear down.
- Turn off IPv6
- Try browsing to some of the computers manually, press Windows key + R, type: \\computername, hit Enter
- Press Windows key + R
Type: services.msc
Hit Enter

1. Start the "Function Discovery Provider Host" and "Function Discovery Resource Publication" services, and then set them toAutomatic (Delayed Start).
2. When you open Explorer Network, enable network discovery when you are prompted.

Press Windows key + X > computer management-->shared folders--> choose the shared folder, right click it then click Properties > Share Permissions -->protection that everyone can read and execute, see folder contents and read permissions.

Add the machine to your Windows HOSTS file.

See this thread for further tips:
Best regards,
Andre Da Costa
Independent Advisor for Directly

19 people found this reply helpful


Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.


Question Info

Last updated January 21, 2021 Views 15,112 Applies to: