WiFi icon showing weird rectangle

WiFi icon has a weird rectangle on top of it.

As you can see, the WiFi icon on the taskbar looks fine, but when I click on it, this rectangular box appears on top of WiFi. The same happens when I check available WiFis in Network and Internet settings.

I am running Windows 10 Home Single Language with latest updates.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi Sushruta Bhattacharjee,
it could be your wireless device, smartphone, tablet, TV etc. that is connecting to your wireless network via WI-FI Direct.
Try temporarily turning off one device at a time and see if the rectangle icon disappears.

Or try to disable the WPS function on the router.

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Thank you, but pardon me for being a total noob in technical matters.

Which devices will I turn off? Those which are connected to my router? Or the router itself?

And how to turn off the WPS function of the router?

EDIT: Just checked my router settings, WPS is NOT turned on. Also turned off every other device connected to the router, still the icon isn't disappearing.

EDIT 2: With a bit of help, disabled WiFi direct from my laptop. Icon still not solved.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi,
if you connect with another pc to the router in wi-fi, the icon with the rectangle reappears?

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi,

Well, I wouldn't know -- I don't have another laptop to test your theory with. However, I must point out that the problem doesn't seem to arise from the WI-FI router, since EVERY single WI-FI (even my phone's hotspot and my neighbour's router) has that weird rectangle on it. The problem seems more local.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

But does your pc work regularly despite the presence of that rectangle?
It could be a wireless device in your area that is located in the field of your PC. Try following these steps:
Settings> Network and Internet> WI-FI, click on the right on Manage known networks, select and then delete all network profiles, then reconnect to your network by re-entering the wi-fi password again. Is the rectangle symbol still there?

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Well, the reason I was attracted to was that my WI-FI was experiencing problems in my laptop (it would work on my mobile but my laptop would show "resolving host" error). It still happens sometimes (once every other day, maybe). I don't know if it is related to the rectangle icon or just some router issue.

And as for the fix you suggested, well, I tried that. Deleted all the profiles and reconnected. Nope, no change. Nada. Still the same.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi Sushruta Bhattacharjee,
temporarily switch off the router and all the other wireless devices in the house, smartphones, tablets, Smart TVs, etc. Just keep your pc turned on. Do you still see the icon of that rectangle in the list of available Wi-Fi networks?

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Same problem here...

I notice that this issue has been there since the 2004 update, before that everything works fine, then suddenly, right after the build 2004 update, this weird shape appeared every time I connect to a secure connection (open wifis are ok)

3 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I had the same problem, i could fix it, you have to found the fount "Segoe MDL2 Assets" in another PC with the same compilation of your windows 10, you can found it in "C:\Windows\Fonts" then you have to copy and paste like this:

and then:

that should fix it. 

8 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I had the same problem, i could fix it, you have to found the fount "Segoe MDL2 Assets" in another PC with the same compilation of your windows 10, you can found it in "C:\Windows\Fonts" then you have to copy and paste like this:

and then:

that should fix it. 

Tried this but no luck :( Is there any other work around on this? Hope someone from Microsoft can help us fix this. The icon is really annoying.

4 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated April 13, 2021 Views 4,051 Applies to: