WiFi disconnects when ethernet is plugged in

Hello, we have problem on Windows 10. When we connect ethernet cable, the WiFi automatically disable WiFi adapter. We checked BIOS, properities of adapters, check presence of third party programs and nothing is set wrong to do that. It started doing after Windows 10 update on December 2018. Is it something in registry?
Answer
Answer
Hi,
I am Ganesh Gandhi, an Independent Advisor and Office Insider for Android. I am here to work with you on this problem.

Kindly follow these steps below and both devices will be functioning concurrently.

1. Go to network and sharing center in control panel.

2. Select change adapter settings

3. Right click on your Ethernet device and select properties on popup menu.

4. In properties menu, click configure button.

5. When configure menu, select advanced tab.

6. In advanced menu, under property list, look for "Priority & Vlan" and select it.

7. Look in value list to the right and select disable toggle.

8. Click Ok, on your way back out of menus and wait 15 seconds until system updates new value.

You have just disabled your Ethernet LAN priority so it will function together with your WIFI.

Also,

Disable 'IPsec Policy Agent' service and
setting the registry key
HKLM\Software\Policies\Microsoft\Windows\WcmSvc\GroupPolicy!fMinimizeConnections to 0.

Prohibit connection to non-domain networks when connected to domain-authenticated network"

GPO Path: Computer Configuration/Administrative Templates/Network/Windows Connection Manager/

RegKey: Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WcmSvc\GroupPolicy fBlockNonDomain


Refer:
https://social.technet.microsoft.com/Forums/en-...

Do let me know if you require any further help on this. I will keep working with you until it's resolved.

Content on the above blog is written by Microsoft MVP so it is safe. However, do watch out for the ads.

22 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Answer
Answer

Hello,

This happens because of higher priority of Ethernet as compared to WiFi. The priority order is Ethernet > WiFi > Cellular. More information provided in this documentation:

 

https://docs.microsoft.com/en-us/windows-hardware/drivers/mobilebroadband/understanding-and-configuring-windows-connection-manager.

Try these steps to use both WiFi and Ethernet as same time:

1. Open Registry Editor.

2. Go to HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\WcmSvc\Local.

3. Create/change the fMinimizeConnections registry DWORD to 0.

4. Close Registry Editor and reboot.

Hope this helps!

___________________________________________________________________________________________________

Microsoft MVP (Windows IT Pro), since 2014 · Windows Insider MVP · Windows Help (www.kapilarya.com)

19 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated April 22, 2021 Views 41,892 Applies to: