WiFi Always Off on Startup - Only Keyboard Combo (Fn+F2) Can Enable Wifi

Ever since I did a clean install of Windows 10, my WiFi is always off on startup. The only way I can enable it is by using Fn+F2 on my keyboard (keyboard shortcut to enable/disable WiFi). Using the WiFi toggle in Settings > Network & Internet doesn't work. The toggle won't change to on.

I have a Gigabyte P34 Notebook, with an Intel Dual Band Wireless-AC 7260 WiFi card. 

It is getting rather annoying to have to always press Fn+F2 to turn WiFi every time I use my laptop, so any help would be greatly appreciated.

Thanks in advance!

|

Hi,

 

I realize that you are facing the issue in switching on Wi-Fi. Let me assist you.

 

This issue might happen if the drivers are not up to date. I suggest you to update the

 

As an initial step of troubleshooting, I suggest you to try connecting the laptop via a wired connection and checked if it works.

 

I suggest you to update the network adapter drivers and check if the issue is resolved.

 

  • Press Windows key + X key and select Device Manager.

  • Find and double click on Network Adapter.

  • Right click on the Wireless adapter option and click on Update driver software.

  • Follow the on-screen instructions and restart the laptop after the update is completed.

 

Also, I suggest you to check for pending updates and install all the pending updates (if any) and check if the issue is resolved.

Go to Settings > Update & Security > Windows Update > Check for Updates.

 

Hope the information helps. Kindly write back to us for further assistance on Windows. We will be happy to assist you.

 

Thank you.

Thank you
Mohan B P

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Thanks for the suggestions. That was one of the first things I checked, but they didn't resolve the issue. 

Is there potentially a batch file I could create that does the same thing as Fn+F2, and then I could just schedule a task to run that on startup? 

I searched around for one but couldn't find anything that worked. 

I appreciate your assistance with this. I'm just stuck and don't know where else to turn. 

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Turns out I'm not very bright. I had "WiFi SmartManager" enabled in the bios > device configuration > wireless lan. I set this to "Enabled" and all is well.

Sorry for the mixup.

5 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi,

 

Thanks for updating to us with the status of your issue and good to know that you issue is resolved. We appreciate you for the time and effort you have spent in troubleshooting the issue.

 

Kindly write back to us for further assistance on Windows, we will be happy to assist you.

 

Thank you.

Thank you
Mohan B P

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated July 22, 2021 Views 9,489 Applies to: