Keyboard layout issue in Remote Desktop

I use W10 Remote Desktop to connect to a Windows 7 Professional (SP1) external computer.

Before that I used W7, Dutch language, American international keyboard and never had problems with these keyboard settings on my external computer (with the same language and keyboard settings).

The use of W10 with the same settings as the old W7 did not work. A lot of special characters did not meet the layout of the keyboard. It appears that the Dutch keyboard layout overrides the American international layout while typing in the external desk top.

I found the solution in a question on this site from 2017 and it seems that Microsoft has still not solved the problem:  https://answers.microsoft.com/en-us/windows/forum/all/keyboard-layout-remote-desktop-app-store/98daedc2-497b-4386-93b0-6aafbee2d844

So please solve this. It took me two days and a lot of anger before I finally found out that this wasn't my fault.

***Original Title: W10 wrong Keyboard layout in Remote Desktop***

Hi,

Thank you for writing to Microsoft Community Forums

We understand your concern as you are having difficulties in keyboard setting for the other PC through Remote Desktop connection.

Let me point you in the right direction, where you would get the appropriate help for this issue. I would suggest you to post your query in TechNet forums, where we have experts and support professionals who are well equipped with the knowledge on Remote Desktop input language to assist you with the appropriate troubleshooting steps.

Also suggest you to refer the sections that says Why do incorrect characters appear in the session?” From this article: Frequently asked questions about the Remote Desktop clients and check if that helps.

Regards,

Aditya Roy

Microsoft Community – Moderator

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Thanks for these suggestions but I tried all of them. Most curious is that I used exactly the same settings as I use for my other laptop (W7 pro Dutch language US international keyboard ), wich couses no problems at all. The only thing that works is changing the language to the same as that form the keyboard. English UK language combined with US keyboard also gives (bit less) conflicting keys.

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I fixed my keyboard mapping issue by deleting Time & Language settings on both computers and deleting any "Preferred Languages" I was not using. In my case I'm using English (United States) on both computers. I deleted English (United Kingdom) on both [actually may have only been on one]. I restarted both computers and now all is well.

4 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated March 6, 2021 Views 5,676 Applies to: