Vista - Error Code: 652 (Can't install KB979906)

Original Title: Microsoft .NET Framework 1.1 SP1 Security Update for Windows Vista and Windows Server 2008 (KB979906)__Installation status: Failed__Error details: Code 652

Microsoft .NET Framework 1.1 SP1 Security Update for Windows Vista and Windows Server 2008 (KB979906)

Installation date: ‎8/‎2/‎2010 7:47 AM

Installation status: Failed

Error details: Code 652

Update type: Important

A security issue has been identified that could allow an attacker to tamper with digitally signed content without being detected, when this content is being consumed by an application that makes use of the Microsoft .NET Framework on a Windows-based system. You can help protect your computer by installing this update from Microsoft. After you install this item, you may have to restart your computer.

More information:
http://go.microsoft.com/fwlink/?LinkId=185333

Help and Support:
http://support.microsoft.com/

Following this error, I found myself searching for the fix trying links as well as ignored installing it for a long time, believing this to be a bug in the code that would find itself worked out after several month.  Still having this issue, I attempted to research this again and discovered this.

I downloaded the file from the IT Professionals area, being a professional this is where I do my downloads.  I attempted to install NDP1.1sp1-KB979906-X86.exe of which I get several error codes following the launch of this file.  First being Internal Error 2908: {62a403FE-2AB1-4CBA-A17B-651AFFACE2CD} and the next error I received I neglected to get and the third error was Error 1935 An error occurred during the installation of assembly 'System, Version="1.0.5000.0",PublicKey Token="b77a5c56193e089",Culture="nutral",FileVersion="1.1.4322.573". Please refer to Help and SUpport for more information. 

The application closes and still failed.  Can any one assist with this issue?

 

Question Info


Last updated April 12, 2018 Views 3,052 Applies to:
Answer
Did you click on Fixit from the article?

 

Yes I did, still no help.

I ended up opening a ticket with Microsoft.  The fix for this (somewhat) Was to completely uninstall all .NET and install the full downloaded applications from the IT area.  I had been installing the default downloads instead of the complete application.  The woman also took me on a few other .NET dowloads and finally the resubmitted request to install went away.

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.