Version 1903: Network Location won't stay private (change public to private, use upper left arrow, come back, and location is again public)

Hello,

When I was 1803, I couldn't find the place in Windows 10 to change the network location for a WIFI access point to change from public to private.  ALSO when I tried to change from public to private using PowerShell, it failed to change.

I upgraded to 1903!  The ability to switch from public to private for a WIFI access point does indeed show up!!  Finally!!

The problem is:  Switching from public to private won't stay!

Steps:

Step One:

Step Two:

Step Three:

Step Four (I use the LEFT ARROW icon on the title bar (upper left hand corner) to return to the previous screen/dialog: 

Step Five:  NOTE:  The network profile / location is back to PUBLIC from the previously set PRIVATE.

As you can clearly see, I'm now back to PUBLIC after clearly setting the network location to be PRIVATE!

To verify this is still the case, I used a different screen / dialog (Control Panel) to see the status of the WIFI access point:

If the system can't change the network location for some reason, Windows 10 should at least give an error message stating why?!

Yes, I have Administrator privileges on the account I'm using to try and change the network location from public to private.

Thank you. 

After making a change did you restart the computer?
-----------
If this answers your question - Then mark it so. Then others may find it.
---------------
Around computers
since 1952
lacrumb

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Bertram

My name is Andre Da Costa; an Independent Consultant, Windows Insider MVP and Windows & Devices for IT MVP. I'm here to help you with your problem.

Try changing the profile again, but before you restart, disable fast startup then see if it sticks.

Press Windows key + X
Click Power options
Click Additional power settings under Related settings
Click Choose what the power button does
Click Change settings that are currently unavailable
Uncheck 'Turn on fast startup (recommended)

Click Save changes.

Click Restart now and see if it works.

Also, try the following step again:

Open Start
Type: powershell
Right click powershell
Click Run as administrator

Type the following at the command prompt then hit Enter:

Get-NetConnectionProfile

This command will list the profiles and from which you need to find the index number

Set-NetConnectionProfile -InterfaceIndex 1 -NetworkCategory Private

Where 1 is the index number of the profile to change so it might be a different number other than 1 on your system.
Best regards,
Andre Da Costa
Independent Advisor for Directly

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

After making a change did you restart the computer?

No, I didn't restart the computer.  Why?  No message from Windows saying it is necessary.  As I understand reboot is not necessary unless told to do so.

Ok, I'll try it, to see if it makes a difference.

Nope, still public even after reboot.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Bertram

My name is Andre Da Costa; an Independent Consultant, Windows Insider MVP and Windows & Devices for IT MVP. I'm here to help you with your problem.

Try changing the profile again, but before you restart, disable fast startup then see if it sticks.

Press Windows key + X
Click Power options
Click Additional power settings under Related settings
Click Choose what the power button does
Click Change settings that are currently unavailable
Uncheck 'Turn on fast startup (recommended)

Click Save changes.

Click Restart now and see if it works.

Also, try the following step again:

Open Start
Type: powershell
Right click powershell
Click Run as administrator

Type the following at the command prompt then hit Enter:

Get-NetConnectionProfile

This command will list the profiles and from which you need to find the index number

Set-NetConnectionProfile -InterfaceIndex 1 -NetworkCategory Private

Where 1 is the index number of the profile to change so it might be a different number other than 1 on your system.

Hello and thank you for your help,

No change - still public - after turning off Fast start plus doing a shutdown, power back on.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I changed from Public to Private on 3 different laptops and then restarted and all remained as Private.
-----------
If this answers your question - Then mark it so. Then others may find it.
---------------
Around computers
since 1952
lacrumb

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I changed from Public to Private on 3 different laptops and then restarted and all remained as Private.

Congratulations!  Glad it works for you.

BTW, I'm on a workstation.  I use the Intel WIFI card for two reasons:

  1. Bluetooth
  2. When my ISP (RCN) is down (as it is now), I change to my Samsung Note 9 Hot Spot.

It should work for a workstation, as well as a laptop, right?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Click Start
Type: cmd
Right click CMD
Click Run as administrator

At the command prompt, type each command then hit Enter:

ipconfig /flushdns
ipconfig /registerdns
ipconfig /release
ipconfig /renew
NETSH winsock reset catalog
NETSH int ipv4 reset reset.log
NETSH int ipv6 reset reset.log

Hit Enter
Exit the prompt then restart

Open Start > Settings > Update & security > Troubleshoot
Scroll down
Click Network adapters
Click Run the Troubleshooter

When complete, restart to see if the problem is resolved.

If that does not work

Press Windows key + X
Click Device Manager
Expand Network Adapters
Select the Network card listed,
Select Update Driver
This should give you a choice of drivers - select the oldest one
Wait a few minutes while it installs the old driver

or

press Windows key + X
Click Device Manager
Expand Network adapters
Right click your adapter
Click Uninstall


Exit Device Manager, restart. Windows 10 should detect the network adapter then reinstall it. Check if you can connect and browse.

also try:

Open Start > Settings > Network & Internet > Status


Scroll to the bottom then click Network reset.
Best regards,
Andre Da Costa
Independent Advisor for Directly

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello everyone and thank y'all for your suggestions and help,

I found out both why I'm having the issue and how to fix it.

The key was the long Internet (ISP: RCN) outage in my area.  It was so long, I started changing both laptops and workstation/desktop to use my phone's (Samsung Note 9) Hot Spot.  (I use T-Mobile and hot spot support is included in my package.)

Of those systems running Windows 10 Pro, all but one of them was having this issue.  One of them - Intel Compute Stick W5 Pro - didn't have the issue at all.

After looking for the differences, I discovered I'd never installed my purchased Anti-Virus / Firewall product - Avast Premier on the Intel Compute Stick W5 Pro.  After all the Intel Compute Stick doesn't have a lot of RAM nor CPU power.

Going back to my other Windows 10 Pro systems, I examined Avast Premier (both the product's settings and the Avast forums).  The firewall settings show the WIFI access port Vana'diel as public.  I changed it to private via Avast and it change to private throughout Windows.

This wasn't user friendly at all.  I can understand - with 20/20 hindsight - why it happened, but it would be GREAT / WONDERFUL, if Windows would tell us when it unsuccessfully changes a value (as in this case).  Maybe give us an idea where the issue resides.  AFTER ALL, none of us figured it out .... till I happen to have to change lots of systems with Avast Premier install on the system.

Again thanks to everyone. 

I'm going to suggest to Avast they honor the change in network location or at least catch it and inform their customers/users on the proper way to change it.

It would be nice for Microsoft to do the same (see above about when change fails).

5 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated September 1, 2020 Views 1,417 Applies to: