TWCU : Failed to load library file

I have just upgraded to Windows 10 from Windows 7. Each time when I start the computer and the desktop is loaded, I get the following error: TWCU

Failed to load library file.

What is this error and how do I fix it? Thank you.

 

Question Info


Last updated August 17, 2019 Views 58,730 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

As well as receiving this message on start up I also see it when I try to open the TP-Link Wireless Configuration Utility. So guessing this set up prog for my TP-Link Modem ROUTER TD-W8970 is not Win 10 compatible.

34 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Just put the question to TP-LINK Support and will post when I hear back.

53 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I see there are now 19 people with the same error message (12.8.15). Can they confirm they are using a TP-Link product and if so also have the TP Link Wireless Configuration Utility?

Looks like this icon on left in task bar. (The one on right is a wireless network watcher not associated).

Error message

967 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Forgot to add I also have a TP-Link 300mps Wireless N PCI Adapter (TL-WN851ND), however my PC is connected by a CAT 6 cable to router although it is inserted. Can't recall if the config util also used for this ... 

17 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I now believe that this error message and utility relate not to my TP Link Router but to the TP-LINK Wireless N PCI Network adapter TL-WN851ND. In my PC its not in use but still inserted. I presently connect router via CAT 6 cable. TP Link support have asked some questions (do other Wi Fi devices operate ok etc) and will let you know their conclusions.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Yes I do have the TPlink Wireless Configuration Utility installed. However I no longer get the error. I installed all available updates from Windows Update.

5 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I too have installed all available updates from Windows Update. But I still have the TP-Link Wireless Configuration utility problem "TWCU - Failed to load library file".

Do we know if Microsoft are investigating this fault ?

16 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi, yes I too have all available Win 10 updates installed but still have the same message.

I have received this reply from TP-Link Support,

Begins:

As you can see, all devices except the win10 computer can work fine with tp-link modem. This means the modem is working properly. And the problem only started when you upgrade to win10, so it maybe have a relation with the win 10 wireless adapter. So you may need to contact with your computer support to upgrade your network adapter in your computer.

Ends.

I should explain that TP-Link support asked me if I had other devices using the router and I replied yes via Wi Fi, (2 X Nexus 7 2013 tablets and SKY TV and a second computer) and they all worked fine. My main PC does not use my installed Wireless Adapter TL-WN851ND as its connected directly via CAT 6 cable to the TD-W8970 router. My second computer running XP uses same brand/model Network adapter and is not connected via a cable to router. Just Wi Fi. The configuration utility is working fine of course with no error message.

I have a program called Wireless Network Watcher that enables me to see what is connected to my router i.e. no unauthorised connections and this program can see both the network cards in both computers connected. So I don't think the card itself is at fault but just that the config utility software is not Win 10 compatible.

Not sure what to make of that support response :o( Sounds like they are suggesting a new Network Adapter.

Richard :- Not been in communication with Microsoft but hopefully this community is monitored? I'm a newbie!

Last thought for the night. The util allows you to see and select which broadband is available to you. Your own and your close neighbours. So if Chetan015 was still using the PC with a network card and no cable for his initial post in this community (before error msg cleared) then somehow the computer  was hanging onto the right connection? Perhaps you have second PC As well? Confused.com

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

To TP-Link Support

BEGINS:

Hello May.Liu,

I agree that the TP-Link Router is working well. I agree the problem seems to be associated with the TP-Link Network adapter. However I do not believe it is the adapter hardware but the software for the TP-Link Wireless Configuration Utility.
 
I have a program called Network Watcher which monitors what devices are connected to my router. This Program is to ensure there is no unauthorised use of my broad band. This program can see both of my Network adapters in both of my computers. The program shows them as active. This leads me to believe it is a software problem due to Windows 10 upgrade which could be corrected by an update.
 
I attach a screen print of my Network Watcher showing all my devices active. I have removed some information for security reasons.
 

Is there any chance that TP-Link can produce a software update as I see the number of users with this problem is increasing daily and one site alone has 35,000 TP-Link Network adapter users so I think you can expect quite a few calls on this subject.

ENDS

I don't hold out much hope of an update but believe there are third party programs that can do the same job and I will research these.

 
 

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Well thought I would do some exploring and here are some screen shots which show the adapter in Device Manager with no error and that it is working. Checked for updated driver but best driver already installed. Tried to reinstall utility and driver from CD but platform incompatible.

16 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.