Taking back control of your folders from OneDrive

When I first set up my computer, I enabled OneDrive, foolishly thinking it might be useful on a limited basis for sharing some information with friends and family.  I just assumed it would be there if I ever wanted to use it.  NOT SO.  That damn thing takes over your computer.  Without knowing, my default Documents and Pictures (not sure why it limited itself to those two folders) was in OneDrive and automatically syncing with the cloud.  I didn't realize what was happening until I went to recover some backup data and found out that there was NO DATA in by backup document file!  OneDrive had redirected everything to it's own document file, and made me think it was in the default document file on C: User.  Sure enough, the Document file that "appears" under "This PC" in File Explorer is actually a OneDrive file and with OneDrive running you can't even set up File Explorer to show you what is (or is not) in your Document file on the PC.  What a mess.  I tried deleting the OneDrive folders and they reappeared.  I tried a number of other things.  After spending two days trying to figure this mess out, I have come to the conclusion that the only way to get control is to get rid of OneDrive.  But it appears OneDrive is not uninstallable, so we have to somehow disable it.

My first attempt was to open the program settings and uncheck the auto run on start-up option, and the "unlink this PC" - Doesn't work; all the folder architecture and overrides created by OneDrive remain in place, and functional.

Here is what finally worked for me.  First, let OneDrive get all synced and cozy with itself.  Then delete every bit of data in every folder created by one drive.  If necessary, go to the Web page version and make sure all the data is gone on both ends.  Now:

1. Right click on program icon, open settings

2. Account Tab - open "choose folders"  and uncheck ALL of the folders (may not work if data remains in a folder).  This is the key step; if you successfully do this, all the OneDrive folders should disappear. If they don't, keep trying until they do

3. Settings tab - uncheck all the General boxes (this step may not be necessary)

4. AutoSave Tab - click update folders and make sure they are all unchecked (again, may not be necessary).

5. On the Account Tab, no click "unlink this PC"

Now you need to make sure OneDrive is disabled.  Here is how to do that:

1.                   Press the Windows key + R shortcut to open the Run command window.

2.                   Type in gpedit.msc.

3.                   Click the OK button.

4.                   Click on the Administrative Templates folder.

5.                   Double-click on the Windows Components folder.

6.                   Double-click on the OneDrive folder.

7.                   Double-click on Prevent the usage of OneDrive for file storage.

8.                   Click the option button beside the word Enabled.

9.                   Click on the OK button.

There you have it.  Now File Explorer will display YOUR Documents file and YOUR other system files (Pictures, etc), and there will be no OneDrive files.  

Microsoft should be ashamed for creating such a mess with OneDrive.  It doesn't need to be this way - I'm sure the whole purpose is to force us to store all our data in OneDrive and instead of providing an alternative solution when we run over the 5 GB limit, we start coughing up the cash for data storage.  Small amount at first... then real money before you know it.  Stupid!

 

Discussion Info


Last updated November 27, 2020 Views 3,600 Applies to: