Starting with Windows 10 2004 the PFA memory list is no longer recognized

Starting with Windows 10-2004 the PFA memory list, as described for example here https://docs.microsoft.com/en-us/windows-hardware/drivers/whea/how-to-manage-the-pfa-memory-list , is no longer recognized.

How to test:
1) Start „regedit.exe“, and export „ Computer\HKEY_LOCAL_MACHINE\HARDWARE\RESOURCEMAP\System Resources” as _text_ to a file A.
2) Choose a memory address to test the functionality. For example 32MB (=0x2000000  page number = 0x2000000 / 0x1000 {page size} = 0x2000).
3) Now open file A and ensure the chosen address (0x2000000) is part of a descriptor below “Physical Memory”, but neither part of “Loader Reserved” nor “Reserved”. Typically 0x2000000 should be fine.
4) Open an administrator command prompt and execute these commands to add the memory at 0x2000000 to the bad memory list by adding its page number 0x2000:
“bcdedit /set {badmemory} badmemorylist 0x2000”
To ensure Windows does not ignore the list this setting is also required:
“bcdedit /set {badmemory} badmemoryaccess no”
To be sure there is no override in the current settings also call: 
“bcdedit /set {current} badmemorylist 0x2000”
“bcdedit /set {current} badmemoryaccess no”
The settings can be verified calling:
“bcdedit /enum {badmemory}”
“bcdedit /enum {current}”
5) Reboot the PC
6) Again start „regedit.exe“, and export „ Computer\HKEY_LOCAL_MACHINE\HARDWARE\RESOURCEMAP\System Resources” as text to another file B.
7) Compare file A and B.

Before Windows 10-2004 files A and B were different, because in file B the faulty page was excluded from usable memory, as you can see in the attached files.

Using Windows 10-2004 the only differences are the timestamps.


We also succeeded in reserving a memory range containing such a bad memory entry by calling “MmAllocateContiguousMemorySpecifyCache” (https://docs.microsoft.com/en-us/windows-hardware/drivers/ddi/wdm/nf-wdm-mmallocatecontiguousmemoryspecifycache).


|
Is it a bug or a feature? :)
AlexeiK

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I hope, it is a bug.

Nobody from Microsoft has answered it and I have not found in 2004 release notes that this feature is disabled.

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated May 10, 2021 Views 418 Applies to: