Spooler subsystem app and high CPU usage

Before sending this, I have Googled the issue and have had no success; this, I am turning here for help.

Recently I have had high CPU usage on my Toshiba Laptop, Windows 10, all latest updates installed.  On checking, I found that it was the spooler subsystem that is using 26-29% CPU.  I have tried all of the fixes that I could find and the problem persists.  (1) For example, I ran the Printer Troubleshooter, and it returned no errors. (2) I checked to ensure that I have the latest drivers installed and I do.  The printer (HP ENVY 5055) prints with no problems.  (3) I stopped the spooler in Administrative Services and then tried to delete any cached print jobs at C:\Windows\System32\spool\PRINTERS.  There were no jobs there.

Does anyone have any ideas as to what else may be wrong?

Thanks for any help.

|
Answer
Answer

Thanks for the reply, Zaki.  I will save it for future reference.

In the meantime, I can report that the problem has disappeared.  I had turned off the spooler to avoid the problem when an update to Windows 10 came out (May 12, 2020—KB4556799 (OS Builds 18362.836 and 18363.836)).  I installed it and when  the computer restarted, the spooler did too and the CPU usage is now back to normal.  Must have been something in the update that fixed things, but in any event, I am now a happy camper.

Thanks again for your reply.

5 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated June 23, 2021 Views 4,907 Applies to: