Sleep Mode Disconnects Ethernet Internet Connection - An Oldie but a Goodie

When my desktop computer goes into sleep mode (hybrid) it disconnects my Ethernet connection to the internet. Upon waking up the computer it will take 15 to 20 seconds for the computer to automatically reconnect my Ethernet connection. I've gone into "Network Adapters" in Device Manager and made sure that there was no check mark next to "Allow the computer to turn off this device" that does not help. I am not using a wireless connection (dual band wireless has been disabled). The connection is hard wired Ethernet. This is a brand new HP Windows 10 computer. Windows 10 states that I am using the most up to date Network Adapter drivers. I've seen this question posted many times dating way back, but I've never seen the answer posted. There has to be an answer.

Hi,

There's a possibility that your Ethernet connection is not enabled to wake on magic packet. For us to isolate this, let's look into the advanced settings of your network adapter. Follow these steps:

  1. Navigate to Device Manager > Network adapters.
  2. Right-click on your Ethernet connection and click Properties.
  3. Click the Advanced tab.
  4. Under Property, scroll down and select Wake on magic packet.
  5. Set the value to Enabled.
  6. Click OK.

Once done, try to observe if Ethernet connection still disconnects if put to sleep mode.

Looking forward to your reply..

Regards.

4 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I set the value to "Enabled" but it still disconnects on sleep. Earlier tonight I went into the "Group Policy Editor" and enabled "Allow network connectivity during connected standby (on battery and plugged in). No go. There is an enable/disable for "only allow a magic packet to wake the computer" setting under the Device mgr/network adapters/Ethernet connection/properties/ power management, but to enable this I would have to check "allow the computer to turn off this device to save power". tried it, no go. Thanks for your hopefully continued help.

2 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Thank you for getting back. Can you go back to your Device Manager and check if a power saver option is available?

  1. Navigate to Device Manager > Network adapters.
  2. Right-click on your Ethernet connection and click Properties.
  3. Click the Advanced tab.
  4. Under Property, scroll down and look for Save power when system... or Energy Efficient Ethernet options.
  5. If you see both or any of the two options, please set the Value to Disabled.
  6. Click OK.

Once done, check again if Ethernet connection still disconnects when computer is put to sleep mode.

Will be waiting for your feedback.

Regards.

15 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated November 24, 2020 Views 16,235 Applies to: