Shift Key Fails using RDP (Remote Desktop) between Windows 10 and Server 2008 R2

This was a recent issue discovered when new computers were installed. Shift key did not respond while using remote desktop from a Windows 10 computer to our Windows 2008 R2 Enterprise edition server.

The fix;

-Open the Remote Desktop application

-Click down arrow at bottom left of application window "Show Options"

- Select "Local Resources" Tab

- Under "Keyboard" you'll see "Apply Windows key combinations"

- Select dropdown menu and change to "On this computer" and then you are done with this tab

- Select the General Tab

- Under "Connection settings" you have the options to select on of these buttons "Save, Save As..., Open..."

- Select the "Save" button

- You are finished, now test!

Note: if you select either of the other two options the shift key did not respond in my environment.

- "Only when using the full screen"

- "On the remote computer"

I hope this helps someone out :)

Was this discussion helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this discussion?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this discussion?

Thanks for your feedback.

 

Discussion Info


Last updated January 19, 2021 Views 1,118 Applies to: