Remote Desktop - How to Increase Lock Timeout

I am on Windows 10 Enterprise. I use Remote Desktop Connection to remote into Windows 2012 and Window 2016 Servers and often move back and forth between my machine one or more remote servers. The timeout period, before the RDC forces me to re-enter my password seems very short; 5 to 10 minutes.

How to I increase this timeout (I'm not sure of the proper term) so that I don't have to enter my password so often. There is no security risk. Is this a setting on my desktop or a setting on the remote server?

|
Answer
Answer

Hello Raymond,

Thank you for reaching out. I am Harun an Independent Advisor and Microsoft User. I will gladly help you out.

The timeout Option for RDP is set on the servers in the Local Group Policy.
To reconfigure it you have to do it with an admin account of the server.

To Configure it please proceed with the following steps:


- Click Windows Start in the Server and type gpedit.msc,
- In the left panel, navigate to:

Computer Configuration > Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Session Time Limits.

- In the right panel, double-click the Set time limit for active but idle Remote Desktop Services sessions policy: in the modal window that will appear, activate it by switching the radio button from Not configured to Enabled, then set the desired amount of time in the drop-down list right below.

- Apply and you are set to go.


Please feel free to ask for more Information and let me know if this helps.

Sincerely

Independent Advisor
Harun

Please see my earlier reply and refrain from answering questions that are beyond the scope of this community.

22 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Answer
Answer
Hello Raymond,

Thank you for reaching out. I am Harun an Independent Advisor and Microsoft User. I will gladly help you out.

The timeout Option for RDP is set on the servers in the Local Group Policy.
To reconfigure it you have to do it with an admin account of the server.

To Configure it please proceed with the following steps:


- Click Windows Start in the Server and type gpedit.msc,
- In the left panel, navigate to:

Computer Configuration > Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Session Time Limits.

- In the right panel, double-click the Set time limit for active but idle Remote Desktop Services sessions policy: in the modal window that will appear, activate it by switching the radio button from Not configured to Enabled, then set the desired amount of time in the drop-down list right below.

- Apply and you are set to go.


Please feel free to ask for more Information and let me know if this helps.

Sincerely

Independent Advisor
Harun
Sincerely
Harun Sakir Oral

39 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated December 3, 2021 Views 31,185 Applies to: