Possible Bug - KB4458469 - Unable to set notepad as default programs

Recently went through a string of clean windows 10 installs trying to fix this on my end.

Was having trouble setting notepad as the default program for certain types of files, .dll's, .meta, cfg.(worked weeks ago)these types of files found when editing game files for modding some types of games. Noticed after one of my clean OS installs that I could set the default program for those types of files, But then went through the Windows update process to "up to date".

It got to me that maybe I installed a recent update and removing one by one of them, came to KB4458469, upon restart was able to set notepad as default program.

Going into control panel - set your default programs - choose default app by file type didn't help.

Each time I tried to set notepad as default, openwith.exe would come up in task manager/details every time I tried to set it. Also, right clicking the file icon and selecting properties, Opens with was set to "Pick an app" and could not be changed by the button to the right of it.

I do not need troubleshooting help on this but would like to know if there is a way to block this update from automatically being installed.

 

Discussion Info


Last updated July 25, 2019 Views 953 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Same thing happens with update KB4462919.

Its replicatable, Did the same on my laptop:

Create a new text document, rename the file extension to any random set of letters, open it, select notepad as default, The icon should remain the same blank white icon and you will have to choose a program again when opening it.

Example video:  https://www.youtube.com/watch?v=vu9vzmVKI3s

I can replicate this as well. I didn't think to uninstall the latest KB however, I resinstalled from scratch 1803 and after installing KB4462919, I couldn't change any file association by any method.

For example, via Explorer using the context menu and Open With, with "Always use this app to open .txt files" checked, on any .txt files. 

I opened Task Manager as well, and saw that an instance of OpenWith.exe was still running. The Open With dialog didn't close with any error following it. It closed as if it worked properly, but File Explorer didn't refresh it's display, and the file association had not been changed. After going through the Open With dialog a few times, I went to look in Task Manager again, and saw multiple instances of OpenWith.exe still running, even though all Open With dialogs closed without showing any error.

It seems the KB was released on Oct 9, 2018. 

https://support.microsoft.com/en-ca/help/4462919/windows-10-update-kb4462919

I'll uninstall it, and report back.

Same here but with different file extensions and apps https://www.youtube.com/watch?v=5hz4_nwKLKM

Yes, I can confirm, removal of KB4462919 resolves the file association issue entirely.

It is also noteworthy, however, that another PC I have is completely unaffected by this issue, and yet it has KB4462919 installed.

Both Win10 builds were the same 17134.345 (atm, the previously affected PC has the build 17134.112).

UPDATE: Installing KB4462933 has the same effect -- i.e., you become unable to associate any files with apps anymore.
I have the same problem. This is ridiculous. I'm not on Insider build, but stable release.

For me it was KB4462919

I was having this issue on a newly created profile.  If it was happening on the pre-existing profile, I had not noticed yet.  I did not have KB4458469 installed but per a thread I found on Reddit, I uninstalled KB4462919 and the problem appears to have gone away.

After refreshing my system in the hopes of fixing this bug, with no success, I removed KB4462933 and was able to assign Notepad to my .srt files.

Thank you for the suggestion and resolution.

I found this problem too. I format my disc "C:" with 1809 version becouse of this, and install 1803, but problem uppears again after automatic update, so I delete KB4462919, and all work fine.

So KB4462919 is bugged !!!

https://support.microsoft.com/en-us/help/4462919/windows-10-update-kb4462919

"Microsoft is working on a resolution and estimates a solution will be available in late November 2018."

NO COMMENT

Same issue here
can not change any default app for any type of file

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.