Not able to print from Guest account.

Original title: Homegroup problems

 

I have a Dell computer running Windows 7 and I joined our family homegroup. Problem is when I try to print from the Guest User account it will not print to the printer. It only goes to .xps file option. I turned on file sharing and all suggested troubleshooter fixes. Now it tells me this computer cannot connect to the Homegroup, yet the administrator user account is fully connected and can even print to the printer. Why can't a guest account do the same thing. I prefer the family to use the guest account so they can't make changes to the computer without checking with me first. Does that have to change?

 

Question Info


Last updated December 1, 2019 Views 1,264 Applies to:
Answer
Answer

Hi,

 

Thank you for posting in Microsoft Community Forum. As per the description you have an issue with printing from a guest account through Homegroup, please be assured that we will do our best to assist you with this issue.

 

I would suggest you to add everyone in the security tab and grant the permissions to have full control as well and check if it helps. To do this, follow the steps below:

Note: You should be logged on as an Administrator to take ownership of files/folders.

 

Step 1:

1. Locate the file or folder on which you want to take ownership in windows explorer.

2. Right click on file or folder and select“Properties” from Context Menu.

3. Click onSecurity tab.

4. Click on“Advanced.

5. Now click on “Owner tab in Advance Security Settings” for User windows

6. Click on “Edit Button and select user” from given Change Owner to list if user or group is not in given list then click on other users or groups. Enter name of user/group as “Everyone” and click ok.

8. Now select “Everyone” User/group and click apply and ok. (Check “Replace owner on subcontainers and objects” if you have files and folder within selected folder)

9. Click ok when Windows Security Prompt is displayed

10. Now Owner name must have changed.

11. Now click Ok to exit from Properties windows.

 

 

Step 2:

Once you havetaken the ownership of file or folder next part comes isGranting Permissions to that file/folder or object.

How to Grant Permissions in Windows 7:

1. Locate the file or folder on which you want to take ownership in windows explorer

2. Right click on file or folder and select“Properties” from Context Menu

3. Click onEdit button in Properties windows Click ok toconfirm UAC elevation request.

4. Click add to add other user or group. Enter name of user/group as “Everyone” and click ok.

5. Now select “Everyone” User/group and under Permission section check the rights which you want to grant i.e. check“Full Control” under the “Allow” column toassign full access rights control permissions to Administrators group.

6. ClickOk for changes to take effect and click ok final ok to exit from Properties window.

 

For more information visit the following link: What are permissions?

 

Hope this information helps. If you have further questions feel free to reply and we would be glad to assist.

Ravinath P
Forum Moderator - Multiple Forums

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.