msftconnecttest redirect not working on windows 10 public wifi

Hi

I have been having problems with public wifi on my laptop since last Nov. Running windows 10.

Every time I try to connect to internet with a restricted site (ie requiring a login/password) browser opens to msftconnecttest://redirect

and never goes any further - get stuck in this loop. It has been an issue since a windows 10 update sometime in fall 2017.

I have tried:  

  changing default browser from edge to IE, (even tried googlechrome)

  reseting internet options (internet options ->advanced-> reset (but not to factory settings to delete all my personal home pages ect)

  fiddling with the VPN settings

None of these seem to work.

Only way I can connect is to use a personal hotspot.

Why is this an ongoing issue?

Please provide a solution that I can copy/paste into a word or text doc that I can post on my desktop so I can remember this again when I travel next time.

 

Question Info


Last updated December 8, 2019 Views 9,184 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

You say you are using a VPN?
Have you contacted your IT department to see if they know what is causing this issue?
I think it might have to do with the network profile configuration.
Meaning your vpn requires private profile.
But when you are connected to a public wifi it uses a public profile.
But when connected to a hotspot it is a private profile.
Can you verify that?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I'm not trying to use VPN, but one of the previous "tips" for resolving this issue did include making a change to the VPN site. I'm just trying to connect through regular wifi to the internet.

What happens is I choose the public connection (with the little exclamation point next to the wifi symbol), and it will say "connected" but there is no internet because of this msftconnecttest not reaching the website to use the login code. 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Reboot your ISP modem.
Also change the home page of your browser so it is not MSN.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

How do I reboot a modem for public wifi?!?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

If you are using a pubic wifi so not your home or work one then they are blocking this on their end

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Seems odd that I can get onto the login page on my iphone (which apparently does not use msftconnecttest as an interim step, but not the laptop. 

Can I bypass this msftconnecttest step manually?

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Are you using an antivirus program besides Defender?
If so disable it and try.

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

No luck. Temporarily disasbled McAfee virus scan and firewall, still would not connect.

Also typed in the IP address of the public wifi (I am able to find it by connecting with my iphone), will not connect.

Added msftconnecttest to "allowed" list of websites in McAfee. Still won't connect.

Why does this work fine on my iphone but not with microsoft?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I agree none of the above hve worked, and i was wondering if theres anyway to move past this. 

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I found a work-around. I am using McAfee protection software, and have "parental controls" enabled on my device. When I turn off the parental controls, I am able to bypass the msfttest error and arrive at the login page for whatever public wifi I am using. So far, this has worked perfectly on each public wifi I tried. Then, once logged on, I can re-enable parental controls and it works fine. 

6 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.