Missing "Open Command Prompt Here" after upgrade to windows 10 Creators update

hello,

I recently upgraded to windows 10 creators update and since then the option in the file menu in explorer that allowed me to open a command prompt with that folder as working folder has disappeared.

The corresponding option for the powershell is still there, but the one for the command prompt has disappeared. How can I have it back?

Thanks. 

Moved from: (Windows / Windows 10 / Windows settings / PC) 

 

Question Info


Last updated May 13, 2019 Views 9,877 Applies to:

Hi Bracco,

We would like to know if you made any recent hardware or software changes to your computer apart from upgrading to Windows 10?

Meanwhile, this issue may occur due to corrupted file or data. We suggest that you follow the steps below and see if it helps:

Step 1: Perform System File Checker (SFC) scan.
 
System File Checker is a utility in Windows that allows users to scan for corruptions in Windows system files and restore corrupted files.

Step 2: Clean boot.
 
It will start Windows by using a minimal set of drivers and start up programs. It will also eliminate software conflicts that could occur when you install a program, or an update, or when you run a program in Windows.

Note:  After clean boot troubleshooting steps, refer to the section "How to reset the computer to start as usual after troubleshooting with clean boot" in the provided link to return your computer to Normal startup mode.

Let us know the details so we could further help.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

https://www.groovypost.com/howto/find-restore-open-command-prompt-windows-10/

Settings\Personalization\Taskbar

Turn off "Replace Command Prompt with Windows Powershell..........."

As well as http://www.winhelponline.com/blog/cmd-here-windows-10-context-menu-add/

16 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Yes Microsoft in their wisdom are phasing out Command Prompt in favour of Powershell . . .

Here are the steps to add that option back to the Context Menu in Windows File Explorer:

  1. Make sure you can see files extensions - In File Explorer, on the View Tab, check the box 'File Name Extensions'
  2. Close File Explorer if it is open
  3. Right click a black space on your Desktop, choose New - Text Document
  4. Copy the text below into it
  5. Save the file and give it a meaningful name
  6. Change the file extension from .txt to .reg
  7. Right click the file and choose 'Merge'
  8. Confirm the merge when asked
  9. That's it, you're done, 'Open Command Prompt Here' will be back on your Shift + Right click menu in File Explorer!

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\Directory\shell\cmdprompt]
@="@shell32.dll,-8506"
"Extended"=""
"NoWorkingDirectory"=""

[HKEY_CLASSES_ROOT\Directory\shell\cmdprompt\command]
@="cmd.exe /s /k pushd \"%V\""

[HKEY_CLASSES_ROOT\Directory\Background\shell\cmdprompt]
@="@shell32.dll,-8506"
"Extended"=""
"NoWorkingDirectory"=""

[HKEY_CLASSES_ROOT\Directory\Background\shell\cmdprompt\command]
@="cmd.exe /s /k pushd \"%V\""

[HKEY_CLASSES_ROOT\Drive\shell\cmdprompt]
@="@shell32.dll,-8506"
"Extended"=""
"NoWorkingDirectory"=""

[HKEY_CLASSES_ROOT\Drive\shell\cmdprompt\command]
@="cmd.exe /s /k pushd \"%V\""

EXTRA NOTE: To add Command Prompt back to the right click of your Start Menu (this only adds Command Prompt back to your Start menu), right click your Taskbar, choose Taskbar Settings and turn this option on . . .

___________________________________________________________________

Power to the Developer!

MSI GV72 - 17.3", i7-8750H (Hex Core), 32GB DDR4, 4GB GeForce GTX 1050 Ti, 256GB NVMe M2, 2TB HDD

57 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Many thanks. Worked a charm.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Glad to help, if you have any more questions, please contact us here at MS Community!
___________________________________________________________________

Power to the Developer!

MSI GV72 - 17.3", i7-8750H (Hex Core), 32GB DDR4, 4GB GeForce GTX 1050 Ti, 256GB NVMe M2, 2TB HDD

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks for your solution! The registry hack successfully works on the shift-right-click in within the explorer menu. 

But additionally, I'd relly love to have that option back at the file menu, as seen above in my screenshot. 

Any help appreciated :-)

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This is what I would also like to know.

I don't know why they are forcing powershell since it's much slower to open than standard cmd and it doesn't behave in the same way.

9 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.