i have a corrupted D3D10Warp.dll file, how can i fix it if sfc can't?

this results in a few programs crashing automatically with similar error messages (skype, msn messenger, windows help, fix it center and fix it, , avira notication tool and in product messaging, giljabi.exe and LG intelligent update it's related to, and the desktop sidebar...so far..)

CBS log says cannot reproject corrupted file; source file in store is also corrupted.

I think this started after i ran ccleaner... tryed to restore from several saved ccleaner registry backups (even from 6 mths ago) , but that didn't fix the problem.

also tried system restore but no restore points have been created on my computer's system disk.. don't they get created automatically? i vaguely remember using this tool to fix an issue on this same computer a few yrs back..and there was restore points available for me to choose from..

also ran full scan with avira and malwarebytes but no issues reported.

This laptop didn't come with windows disk. the OS was already installed when i bought it from the store.

So should i replace the file?
If so, where can i find one?, and how do i proceed without making more of a mess?

Thanks for th help.

Question Info

Last updated January 4, 2020 Views 6,028 Applies to:

It appears you had a version before that update. Have you access to other vista computers?


The file is sytem32 and the one with the same version in WinSxS are the same file. A hard link is a filename. Every file has at least one hard link. Files in system32 and files in WinSxS are usually hardlinks to the same file. Therefore copying from WinSxS won't help.

To replace the file if you can find a copy.


Click Start - All Programs - Accessories - Right click Command Prompt and choose Run As Administrator. Type

takeown /f %windir%\system32\d3d10warp.dll  /a
icacls %windir%\system32\en-US\d3d10warp.dll  /grant Administrators:f

If you can't delete it because it is in use you should be able to rename it.


ren %windir%\system32\d3d10warp.dll %windir%\system32\d3d10warp.dll.bak


copy <path to new file>\d3d10warp.dll %windir%\system32\d3d10warp.dll




You could try an earlier or later version to copy over.

1 person was helped by this reply


Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.